Bug 127207 - [PATCH] keymap "fi" does not work properly
[PATCH] keymap "fi" does not work properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rdesktop (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: i18n, Patch
Depends On:
Blocks: FC3Target FC2Update
  Show dependency treegraph
 
Reported: 2004-07-03 20:39 EDT by Jarkko
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.3.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 11:50:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarkko 2004-07-03 20:39:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The "fi" keymap does not work properly. For example I can't get "&" at
all.

Version-Release number of selected component (if applicable):
rdesktop-1.3.1-3

How reproducible:
Always

Steps to Reproduce:
1. choose the "fi" keymap
2. connect to some Windows server
3. try to push "&"
    

Actual Results:  Nothing happens.

Expected Results:  The key should print "&" on the screen as normally.

Additional info:
Comment 1 Warren Togami 2004-07-04 01:06:41 EDT
Can anybody else confirm this problem?
Comment 2 Ville Skyttä 2004-07-04 05:20:22 EDT
Confirmed.  The keys @&<>' do not work in the shipped fi keymap for
me.  I have already posted a patch that fixes this for me upstream, it
would be very nice to get this applied in RH/FC.
http://sourceforge.net/tracker/index.php?func=detail&aid=959504&group_id=24366&atid=381349
Comment 3 Jarkko 2004-07-05 01:27:59 EDT
Applied the patch. Everyhing seems to be working ok now, but I'm
getting the following warning:

WARNING: No translation for (keysym 0xfe03, ISO_Level3_Shift)
Comment 4 Jarkko 2004-07-05 01:36:46 EDT
Hmm, that warning must have been there already because the patch
contained only additions. 

It might be a good idea though to check out what key should that
(keysym 0xfe03, ISO_Level3_Shift) be so that we get rid of that warning.
Comment 5 Ville Skyttä 2004-07-05 02:42:44 EDT
Actually, the patch removes 5 mappings (ie. those of the keys that did
not work, some of which are duplicated in the original), it does not
add anything.
Comment 6 Jarkko 2004-07-05 02:52:01 EDT
Oh, I was diffing the files wrong way. :)

So I'm not sure if that warning was there before this patch or not. 
Propably it was (if I understand the keymap files correctly).
Comment 7 Ville Skyttä 2004-07-05 12:41:40 EDT
My patch does not affect the ISO_Level3_Shift warning, it was there
already before.  AFAICS it's purely cosmetic, harmless warning, but
nevertheless fixed in upstream CVS:
http://cvs.sourceforge.net/viewcvs.py/rdesktop/rdesktop/keymaps/modifiers?r1=1.5&r2=1.6&diff_format=u

It would be nice to include that fix as well in FC.
Comment 8 Ville Skyttä 2004-07-05 12:42:43 EDT
(Oh, and ISO_Level3_Shift is AltGr, without the upstream patch a
warning is printed every time it is pressed.)
Comment 9 Jarkko 2004-07-06 02:36:05 EDT
Thanks for that fix. Everything is now working exactly like it should.

So just release a new rpm in updates with these two patches applied
and this bug can be closed. :)

By the way, that second ISO_Level3_Shift patch link says the following
(I had to download the whole file instead): 

===================================================================
RCS file: /cvsroot/rdesktop/rdesktop/keymaps/modifiers,v
retrieving revision 1.5
Unable to create temp directory: Permission denied
Comment 10 Ville Skyttä 2004-07-08 13:37:41 EDT
Yeah, sf.net has the habit of breaking their CVS and/or CVSweb far too
often.  Anyway, the diff link in comment 7 works now; could we get
these fixes in, at least for FC3, even better if also a FC2 erratum? 
That would result in many happy Finns :)
Comment 11 Mark McLoughlin 2004-09-24 11:50:23 EDT
Okay, warren seems to have added this patch. Seems to be in
rdesktop-1.3.1-5 which is in FC3 test2.

Note You need to log in before you can comment on or make changes to this bug.