Bug 1272093 - upstart plugin does not collect any useful data
upstart plugin does not collect any useful data
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Moravec
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 09:32 EDT by Martin Frodl
Modified: 2015-10-16 04:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 11:23:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2015-10-15 09:32:14 EDT
Description of problem:

On RHEL 7, sosreport's upstart plugin has been largely replaced by the systemd plugin. From the log, it does not seem to collect any relevant data: none of the referenced files exist and the commands, if executed at all, produce a useless output (such as "init: unrecognized option '--version'" or "ls: cannot access /etc/init/: No such file or directory").

Is there any reason to keep it in sos, even if disabled be default?

Version-Release number of selected component (if applicable):
sos-3.2-15.el7.noarch
Comment 2 Bryn M. Reeves 2015-10-15 11:23:24 EDT
We support more than a dozen different distributions from the same upstream codebase: some use classical SysV init, some use Upstart, others systemd.

This not a bug any more than e.g. the existence of a Red Hat specific plugin would be in a CentOS, Debian or Ubuntu environment.
Comment 3 Bryn M. Reeves 2015-10-15 11:26:59 EDT
Also, I don't see why this is running on your system at all - the plugin will only trigger if a package named 'upstart' exists:

 20 class Upstart(Plugin, RedHatPlugin, DebianPlugin, UbuntuPlugin):
 21     """Upstart init system
 22     """
 23 
 24     plugin_name = 'upstart'
 25     profiles = ('system', 'services', 'boot')
 26     packages = ('upstart',)
 27 

Is that the case on your system? Or is it being force-enabled via the command line?
Comment 4 Martin Frodl 2015-10-16 04:06:03 EDT
(In reply to Bryn M. Reeves from comment #3)

> Is that the case on your system? Or is it being force-enabled via the
> command line?

Force-enabled indeed. Sorry about the fuss.

Note You need to log in before you can comment on or make changes to this bug.