Bug 1272103 - Error message appearing when running vim : "Unable to import powerline, is it installed?" but everything looks fine.
Summary: Error message appearing when running vim : "Unable to import powerline, is it...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: powerline
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schneider
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-15 13:56 UTC by Fujisan
Modified: 2019-02-25 19:07 UTC (History)
2 users (show)

Fixed In Version: powerline-2.3-1.fc23 powerline-2.3-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-09 21:54:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Fujisan 2015-10-15 13:56:35 UTC
Description of problem:
When I start vim (or gvim), I get the following error message on the terminal:

$ vi /usr/share/vim/vimfiles/plugin/powerline.vim
Traceback (most recent call last):
  File "<string>", line 4, in <module>
ImportError: No module named 'powerline'
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
  File "<string>", line 9, in <module>
ImportError: No module named 'powerline'
An error occurred while importing powerline module.
This could be caused by invalid sys.path setting,
or by an incompatible Python version (powerline requires
Python 2.6, 2.7 or 3.2 and later to work). Please consult
the troubleshooting section in the documentation for
possible solutions.
Unable to import powerline, is it installed?
Press ENTER or type command to continue


Version-Release number of selected component (if applicable):
powerline-2.2-2.fc22.x86_64
vim-powerline-2.2-2.fc22.noarch

How reproducible:
Always

Steps to Reproduce:
1. Just run vim in terminal
2. message appears on terminal
3. press ENTER and everything looks fine. Powerline has been imported as usual.

Additional info:
I didn't have the problem with the previous release of powerline 2.1-1.

The message "Unable to import powerline, is it installed?" comes from file /usr/share/vim/vimfiles/plugin/powerline.vim (line 112) in vim-powerline package.

Comment 1 Fedora Update System 2015-10-20 14:29:39 UTC
powerline-2.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9d6632c476

Comment 2 Fedora Update System 2015-10-20 14:44:13 UTC
powerline-2.3-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-30494f69c4

Comment 3 Fedora Update System 2015-10-20 21:57:21 UTC
powerline-2.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update powerline'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9d6632c476

Comment 4 Fedora Update System 2015-10-26 18:31:26 UTC
powerline-2.3-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update powerline'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-30494f69c4

Comment 5 Fedora Update System 2015-11-09 21:54:05 UTC
powerline-2.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2015-11-10 00:24:11 UTC
powerline-2.3-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Scott R. Godin 2019-02-25 17:46:02 UTC
Description of problem: vim-powerline, when installed reports errors in terminal when launching vim or gvim


Version-Release number of selected component (if applicable): vim-powerline-2.7-1.fc29.noarch


How reproducible: every time


Steps to Reproduce:
1. install vim-powerline plugin via dnf
2. run vim or gvim from a terminal
3. ...
4. Profit?

Actual results:
12:27 PM {1038} localhost: ~>$ gvim
Traceback (most recent call last):
  File "<string>", line 9, in <module>
ImportError: No module named powerline.vim
An error occurred while importing powerline module.
This could be caused by invalid sys.path setting,
or by an incompatible Python version (powerline requires
Python 2.6, 2.7 or 3.2 and later to work). Please consult
the troubleshooting section in the documentation for
possible solutions.
Unable to import powerline, is it installed?


Expected results:
12:27 PM {1038} localhost: ~>$ gvim
12:27 PM {1039} localhost: ~>$

Additional info: removing vim-powerline makes the problem go away, so I am certain it is not being caused by anything in my personal ~/.vim/* or ~/.g?vimrc


I noticed a bug filed back in fedora 22 was marked as fixed ( bug 1272103 ), but apparently it is still present in F29, so I am re-opening this bug rather than filing a new one

Comment 8 Scott R. Godin 2019-02-25 19:07:09 UTC
Further testing has proven I had plugin conflicts with TWO separate plugins in vim -- older versions of both pandoc.vim and vdebug.vim which upon removal cleaned up the error report -- sorry for the false positive.


Note You need to log in before you can comment on or make changes to this bug.