Bug 1272106 - Crash during session saving
Crash during session saving
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 09:57 EDT by Florian Müllner
Modified: 2015-11-19 02:21 EST (History)
4 users (show)

See Also:
Fixed In Version: mutter-3.14.4-16.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:21:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 756642 None None None Never

  None (edit)
Description Florian Müllner 2015-10-15 09:57:20 EDT
Mutter crashes during session saving if any window is set to show on all workspaces: http://faf-report.itos.redhat.com/reports/11308/

The fix in the linked upstream bug is straight-forward, but untested, so this will need some testing if we include it in 7.2. The session restore code should deal gracefully without saved workspaces, but that would need testing as well.
Comment 4 Matthias Clasen 2015-10-15 11:56:54 EDT
Florian, can you produce a test build for qe ?
Comment 16 errata-xmlrpc 2015-11-19 02:21:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2216.html

Note You need to log in before you can comment on or make changes to this bug.