Bug 1272109 - Dnf very slow with wildcards.
Summary: Dnf very slow with wildcards.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-15 13:59 UTC by Mark van Rossum
Modified: 2016-12-02 15:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 13:47:50 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark van Rossum 2015-10-15 13:59:44 UTC
Description of problem:
Dnf is much slower than yum when it is given wildcards in the arguments.

For instance:
dnf update \[a-h]*
takes over 1 minute, while there is nothing to do.

without wildcards
dnf update
takes less than 2 secs.


Version-Release number of selected component (if applicable):
dnf-1.1.3-1.fc22.noarch


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Honza Silhan 2015-10-21 13:47:50 UTC
True.

*** This bug has been marked as a duplicate of bug 1225501 ***

Comment 2 Jaroslav Mracek 2016-11-15 11:50:10 UTC
The performance should be solved by Pull-Request: https://github.com/rpm-software-management/dnf/pull/649


Note You need to log in before you can comment on or make changes to this bug.