This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1272158 - rfe - pam_tally2 report all fail counts in secure log
rfe - pam_tally2 report all fail counts in secure log
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pam (Show other bugs)
6.7
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Tomas Mraz
Dalibor Pospíšil
: FutureFeature
Depends On:
Blocks: 1271982
  Show dependency treegraph
 
Reported: 2015-10-15 11:20 EDT by Striker Leggette
Modified: 2016-05-10 20:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: pam-1.1.1-22.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1344649 (view as bug list)
Environment:
Last Closed: 2016-05-10 20:25:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Striker Leggette 2015-10-15 11:20:10 EDT
Description of problem:
 - RFE for pam_tally2 to report all fail counts in secure log

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

Oct 15 11:04:48 el6server unix_chkpwd[1964]: password check failed for user (lockme)
Oct 15 11:04:48 el6server sshd[1962]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=localhost  user=lockme
Oct 15 11:04:49 el6server sshd[1962]: Failed password for lockme from ::1 port 50904 ssh2
Oct 15 11:04:52 el6server unix_chkpwd[1965]: password check failed for user (lockme)
Oct 15 11:04:55 el6server sshd[1962]: Failed password for lockme from ::1 port 50904 ssh2
Oct 15 11:04:56 el6server unix_chkpwd[1966]: password check failed for user (lockme)
Oct 15 11:04:58 el6server sshd[1962]: Failed password for lockme from ::1 port 50904 ssh2
Oct 15 11:04:58 el6server sshd[1963]: Connection closed by ::1
Oct 15 11:04:58 el6server sshd[1962]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=localhost  user=lockme
Oct 15 11:05:02 el6server unix_chkpwd[1970]: password check failed for user (lockme)
Oct 15 11:05:02 el6server sshd[1968]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=localhost  user=lockme
Oct 15 11:05:04 el6server sshd[1968]: Failed password for lockme from ::1 port 50905 ssh2
Oct 15 11:05:06 el6server sshd[1968]: pam_tally2(sshd:auth): user lockme (502) tally 5, deny 4
Oct 15 11:05:06 el6server unix_chkpwd[1971]: password check failed for user (lockme)
Oct 15 11:05:07 el6server sshd[1968]: Failed password for lockme from ::1 port 50905 ssh2
Oct 15 11:05:08 el6server sshd[1968]: pam_tally2(sshd:auth): user lockme (502) tally 6, deny 4
Oct 15 11:05:09 el6server unix_chkpwd[1972]: password check failed for user (lockme)
Oct 15 11:05:10 el6server sshd[1968]: Failed password for lockme from ::1 port 50905 ssh2
Oct 15 11:05:10 el6server sshd[1969]: Connection closed by ::1
Oct 15 11:05:10 el6server sshd[1968]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=localhost  user=lockme

Expected results:

Oct 15 11:04:48 el6server unix_chkpwd[1964]: password check failed for user (lockme)
Oct 15 11:04:48 el6server sshd[1962]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=localhost  user=lockme
Oct 15 11:04:49 el6server sshd[1962]: Failed password for lockme from ::1 port 50904 ssh2
Oct 15 11:05:06 el6server sshd[1968]: pam_tally2(sshd:auth): user lockme (502) tally 2, deny 4
Oct 15 11:04:52 el6server unix_chkpwd[1965]: password check failed for user (lockme)
Oct 15 11:04:55 el6server sshd[1962]: Failed password for lockme from ::1 port 50904 ssh2
Oct 15 11:05:06 el6server sshd[1968]: pam_tally2(sshd:auth): user lockme (502) tally 3, deny 4
Oct 15 11:04:56 el6server unix_chkpwd[1966]: password check failed for user (lockme)
Oct 15 11:04:58 el6server sshd[1962]: Failed password for lockme from ::1 port 50904 ssh2
Oct 15 11:05:06 el6server sshd[1968]: pam_tally2(sshd:auth): user lockme (502) tally 4, deny 4
Oct 15 11:04:58 el6server sshd[1963]: Connection closed by ::1
Oct 15 11:04:58 el6server sshd[1962]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=localhost  user=lockme
Oct 15 11:05:02 el6server unix_chkpwd[1970]: password check failed for user (lockme)
Oct 15 11:05:02 el6server sshd[1968]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=localhost  user=lockme
Oct 15 11:05:04 el6server sshd[1968]: Failed password for lockme from ::1 port 50905 ssh2
Oct 15 11:05:06 el6server sshd[1968]: pam_tally2(sshd:auth): user lockme (502) tally 5, deny 4
Oct 15 11:05:06 el6server unix_chkpwd[1971]: password check failed for user (lockme)
Oct 15 11:05:07 el6server sshd[1968]: Failed password for lockme from ::1 port 50905 ssh2
Oct 15 11:05:08 el6server sshd[1968]: pam_tally2(sshd:auth): user lockme (502) tally 6, deny 4
Oct 15 11:05:09 el6server unix_chkpwd[1972]: password check failed for user (lockme)
Oct 15 11:05:10 el6server sshd[1968]: Failed password for lockme from ::1 port 50905 ssh2
Oct 15 11:05:10 el6server sshd[1969]: Connection closed by ::1
Oct 15 11:05:10 el6server sshd[1968]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=localhost  user=lockme

Additional info:
Comment 8 errata-xmlrpc 2016-05-10 20:25:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0901.html

Note You need to log in before you can comment on or make changes to this bug.