Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1272166 - in the rendering of the details of a service hosted on vcenter, a ui only worker tries to connect to vcenter
Summary: in the rendering of the details of a service hosted on vcenter, a ui only wor...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.4.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.6.0
Assignee: Greg McCullough
QA Contact: Alex Newman
URL:
Whiteboard: vsphere
Depends On:
Blocks: 1290174
TreeView+ depends on / blocked
 
Reported: 2015-10-15 15:38 UTC by Felix Dewaleyne
Modified: 2019-11-14 07:03 UTC (History)
11 users (show)

Fixed In Version: 5.6.0.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1290174 (view as bug list)
Environment:
Last Closed: 2016-06-29 15:00:44 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1993783 0 None None None Never
Red Hat Product Errata RHBA-2016:1348 0 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Felix Dewaleyne 2015-10-15 15:38:59 UTC
Description of problem:
in the rendering of the details of a service hosted on vcenter, a ui only worker tries to connect to vcenter.

Version-Release number of selected component (if applicable):
5.4.2

How reproducible:


Steps to Reproduce:
1.setup an appliance to only run the web_ui worker
2.on that appliance use iptables to block access to the vcenter environment
3. display the details of a catalog item hosted on vcenter

Actual results:
a connection is established to vcenter on port 443

Expected results:
no connection is made

Additional info:
this connection causes a delay of 60s added to the activerecord part of the rendering and is not logged as an error anywhere.

Comment 2 Felix Dewaleyne 2015-10-16 14:03:10 UTC
this also happens if the UI appliance is in a different zone :

1 - connnect a vcenter to your cloudforms environment ; create a catalog item stored on vcenter as well
2 - set up a new appliance with web UI worker only 
3 - set up a new zone called "ui" and move the appliance there
4 - disconnect from the appliance & reconnect
5 - block connection to the vcenter environment from the appliance with iptables
6 - access the details of an existing catalog item stored in vcenter

result :

netstat -anop

shows a connection attempt to the vcenter environment. the loading of the details of the catalog item will have caused the connection attempt and will increase loading times by 60 seconds.

Comment 4 Felix Dewaleyne 2015-10-16 14:04:19 UTC
Created attachment 1083675 [details]
screenshot2.png

Comment 8 Greg McCullough 2015-10-19 18:50:12 UTC
There is currently an RFE (Bug 1053277) for adding support for distributed switches.  Once this support is added to the DB the provisioning dialog workflow can be updated to use it instead of making direct calls.

Comment 9 Greg McCullough 2016-05-12 15:30:25 UTC
Fixed in PR https://github.com/ManageIQ/manageiq/pull/8434

Comment 10 Alex Newman 2016-06-09 19:20:51 UTC
5.6.0.9-rc2.20160531154046_b4e2f6d

Comment 12 errata-xmlrpc 2016-06-29 15:00:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.