Bug 127218 - yum is *extremely* slow when resolving dependencies
yum is *extremely* slow when resolving dependencies
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-07-04 13:30 EDT by Florian Effenberger
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-30 01:07:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Florian Effenberger 2004-07-04 13:30:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
yum is *extremely* slow when resolving dependencies. I run on a AMD
K6-500 machine and have the following in my /etc/yum.conf:


name=Fedora Core $releasever - $basearch - Base

name=Fedora Core $releasever - $basearch - Released Updates

name=Fedora Core $releasever - $basearch - Unreleased Updates

name=Fedora Core $releasever - Development Tree

When installing a package, e.g. via "yum install openssl-devel", it
takes ages at the "Resolving dependencies" step. The computer doesn't
seem to do much (no high CPU load, no hard disk usage).

My /etc/fedora-release says "Fedora Core release 2 (Tettnang)" and the
kernel version is 2.6.7-1.469.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. yum install openssl-devel (or any other package)

Actual Results:  Takes a long time at "Resolving dependencies" (minutes!)

Expected Results:  Should get *much* faster

Additional info:
Comment 1 Florian Effenberger 2004-07-04 13:39:06 EDT
I have to correct myself:
The CPU load is about 0.99. (no other services are running)
However, there is no remarkable hard disk access as I said.
Comment 2 Florian Effenberger 2004-07-04 13:43:32 EDT
I've measured the time. It takes about 11 (eleven!) minutes to resolve
the dependencies of openssl-devel.

I will do the following:
[install: openssl-devel 0.9.7a-39.i386]
I will install/upgrade these to satisfy the dependencies:
[deps: e2fsprogs-devel 1.35-8.i386]
[deps: zlib-devel]
[deps: krb5-devel 1.3.4-1.i386]
Is this ok [y/N]: y
Comment 3 Seth Vidal 2004-07-04 14:03:18 EDT
Google a bit, this is known and it is being worked on.

Reporting it for the Nth time just annoys the primary developer.

Comment 4 Florian Effenberger 2004-07-04 15:17:26 EDT
I searched, but I did not find anything. Is there a workaround?
Comment 5 Seth Vidal 2004-07-04 15:19:27 EDT
it improves if you:
use fewer repositories - and especially don't mix and match fc2 stable
and development trees.

if you want to use devel then just use devel, not some of fc2 AND devel.
Comment 6 Florian Effenberger 2004-07-04 15:24:03 EDT
Okay, thanks, I'll try! ;-)
Comment 7 Seth Vidal 2004-09-02 14:24:14 EDT
Once fc3test2 is released. Try yum from there, see if it is better.

All reports and tests have said yes, so far.
Comment 8 Seth Vidal 2004-11-30 01:07:18 EST
reports from yum 2.1.X from fc3 say resolution speed is much much much

Note You need to log in before you can comment on or make changes to this bug.