Bug 1272180 - Horizon doesn't load when deploying without pacemaker
Horizon doesn't load when deploying without pacemaker
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: rdo-manager (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity high
: ---
: Liberty
Assigned To: Giulio Fidente
yeylon@redhat.com
:
Depends On:
Blocks: 1281590
  Show dependency treegraph
 
Reported: 2015-10-15 12:32 EDT by Marius Cornea
Modified: 2016-04-18 02:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1281590 (view as bug list)
Environment:
Last Closed: 2016-03-30 19:00:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 235484 None None None Never

  None (edit)
Description Marius Cornea 2015-10-15 12:32:45 EDT
Description of problem:
When deploying keepalived controller Horizon won't load because the default vhost takes precedence over the horizon one.

Version-Release number of selected component (if applicable):
openstack-heat-templates-0.0.1-dev381.el7.centos.noarch
openstack-tripleo-heat-templates-0.8.7-dev284.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy 1 x controller + 1 x compute with isolated networks and keepalived:
openstack overcloud deploy --templates ~/templates/my-overcloud -e ~/templates/my-overcloud/environments/network-isolation.yaml -e ~/templates/network-environment.yaml -e ~/templates/firstboot-environment.yaml  --control-scale 1 --compute-scale 1  --libvirt-type qemu
2. Check /etc/httpd/conf.d/

Actual results:
Both 15-default.conf and 15-horizon_vhost.conf are present so the default takes precedence. 

Expected results:
The horizon vhost takes precedence. 

Additional info:
It looks that the non-pacemaker deployment doesn't set the vhost priority:
 
https://github.com/openstack/tripleo-heat-templates/blob/master/puppet/manifests/overcloud_controller.pp#L464

Note You need to log in before you can comment on or make changes to this bug.