Bug 1272203 - When the value of manage_repos is blank, the output of 'repos --list' is not reasonable.
When the value of manage_repos is blank, the output of 'repos --list' is not ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-rhsm (Show other bugs)
6.8
Unspecified Unspecified
low Severity low
: pre-dev-freeze
: ---
Assigned To: William Poteat
John Sefler
: Triaged
Depends On: 1251853
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 14:38 EDT by J.C. Molet
Modified: 2016-05-10 16:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1251853
Environment:
Last Closed: 2016-05-10 16:37:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Barnaby Court 2015-11-16 15:48:05 EST
We should either report that we are using the default or error because the config is bad.
Comment 4 qianzhan 2016-01-11 00:24:11 EST
Verified.

Version-Release number of selected component (if applicable):

subscription-manager: 1.16.6-1.el6
python-rhsm: 1.16.5-1.el6


1. Unset manage_repos field and yum considers using managed repositories as default with square brackets:

[root@dhcp-128-64 ~]# subscription-manager register 
Registering to: samserv.redhat.com:443/sam/api
Username: admin
Password: 
The system has been registered with ID: 264d5fb6-d468-4511-8000-e49c42fb0728 

[root@dhcp-128-64 ~]# subscription-manager config | grep manage_repos
   manage_repos = [1]

[root@dhcp-128-64 ~]# subscription-manager list --consumed
No consumed subscription pools to list

[root@dhcp-128-64 ~]# subscription-manager config --rhsm.manage_repos=""

[root@dhcp-128-64 ~]# subscription-manager config | grep manage_repos
   manage_repos = [1]

2. Attach subscription and unset manage_repos, and yum considers using managed repositories as default with square brackets.

[root@dhcp-128-64 ~]# subscription-manager attach --auto


Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed


[root@dhcp-128-64 ~]# subscription-manager config --rhsm.manage_repos=""
[root@dhcp-128-64 ~]# subscription-manager config | grep manage_repos
   manage_repos = [1]
[root@dhcp-128-64 ~]# subscription-manager repos --list
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   rhel-6-server-rhn-tools-beta-source-rpms
Repo Name: RHN Tools for Red Hat Enterprise Linux 6 Server Beta (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/6/$releaseve
           r/$basearch/rhn-tools/source/SRPMS
Enabled:   0



Moving the bug from ON_QA to VERIFIED.
Comment 6 errata-xmlrpc 2016-05-10 16:37:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.