Bug 1272216 - input a host/ip which is not rhev-m: list index out of range
input a host/ip which is not rhev-m: list index out of range
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-vdsm (Show other bugs)
3.6.0
All Linux
high Severity medium
: ovirt-3.6.1
: 3.6.0
Assigned To: Douglas Schilling Landgraf
cshao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 15:14 EDT by Douglas Schilling Landgraf
Modified: 2016-03-09 09:41 EST (History)
7 users (show)

See Also:
Fixed In Version: ovirt-node-plugin-vdsm-0.6.1-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:41:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47386 master MERGED engine_page: Improve error handling during registration Never
oVirt gerrit 48688 ovirt-3.6 MERGED engine_page: Improve error handling during registration Never

  None (edit)
Description Douglas Schilling Landgraf 2015-10-15 15:14:05 EDT
Description of problem:

In RHEV-H Text User Interface, use as input a non RHEV-M address and it shows an error "list index out of range".


Version-Release number of selected component (if applicable):

Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151009.0.el7ev)
ovirt-node-plugin-vdsm-0.6.1-1.el7ev.noarch

How reproducible:

#1 RHEV-H TUI
#2   Engine/RHEV-M tab
#3   Input a host which is not RHEV-M
Comment 2 yileye 2015-10-15 23:21:31 EDT
yeah,it have this problem in rhev-hypervisor7-7-7.2-20150928.0

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7-7.2-20150928.0
ovirt-node-plugin-vdsm-0.6.1-1.el7ev.noarch
ovirt-node-3.3.0-0.10.20150928gite7ee3f1.el7ev.noarch

Steps to Reproduce:
 1. TUI clean install rhev-hypervisor7-7-7.2-20150928.0 successful with no error.
 2. IN ‘Network‘ Page,Enable NIC via DHCP.
 3. In ‘Engine’ page ,Input  a invalid Engine FQDN  address.
 4. Click ‘Save’.
 after step4, output some message:

┌──────────────────────────────────────────────────────────────────────────────────────── Transaction: Configuring Engine ────────────────────────────────────────────────────────────────────────────────────────┐
│Transaction: Configuring Engine                                                                                                                                                                                  │
│                                                                                                                                                                                                                 │
│                                                                                                                                                                                                                 │
Checking pre-conditions                                                                                                                                                                                       │
│(1/2) Setting root password and starting sshd                                                                                                                                                                    │
│(2/2) Registering oVirt Node...                                                                                                                                                                                  │
│                                                                                                                                                                                                                 │
│An error occurred while applying the changes:                                                                                                                                                                    │
│list index out of range
Comment 3 yileye 2015-11-23 23:40:00 EST
I can' t verified this bug,because we get the latest version is not include
the fixed In version:ovirt-node-plugin-vdsm-0.6.1-4.el7,so wait to new version to verified.
Comment 4 yileye 2015-12-01 22:03:56 EST
I can reproduce this bug on ovirt-node-plugin-vdsm-0.6.1-1.el7ev.noarch

Test version:
rhev-hypervisor7-7.2-20151201.2
ovirt-node-plugin-vdsm-0.6.1-4.el7ev.noarch

Steps to Reproduce:
 1. TUI clean install rhev-hypervisor7-7-7.2-20150928.0 successful with no error.
 2. IN ‘Network‘ Page,Enable NIC via DHCP.
 3. In ‘Engine’ page ,Input an invalid Engine FQDN  address.
 4. Click ‘Save’.

Test result:
after step4, output some message:

Transaction: Configuring RHEV-M                                                             │                                                                                                                                                                               Checking pre-conditions ...                                                                 │
│(1/1) Registering oVirt Node...                                                             │
│                                                                                            │
│An error occurred while applying the changes:                                               │
│Cannot register the node into 10.66.10.238!                                                 │
│Connection refused to 10.66.10.238                                                          │
│Full log: /var/log/vdsm/register.log 

Additional info:
#ovirt-node.log
<snip>
2015-12-02 02:27:07,974       INFO Current page is 'RHEV-M'
2015-12-02 02:27:11,274    WARNING No widget for path action.register
2015-12-02 02:27:11,275    WARNING No widget for path action.register
2015-12-02 02:27:11,294       INFO Running <function <lambda> at 0x8594848>
2015-12-02 02:27:15,021       INFO Captured nothing
2015-12-02 02:27:15,021       INFO An exception during the transaction: Cannot register the node into 10.66.10.238!
Connection refused to 10.66.10.238
Full log: /var/log/vdsm/register.log
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 956, in __run_transaction
    self.plugin.dry_or(lambda: tx_element.commit())
  File "/usr/lib/python2.7/site-packages/ovirt/node/plugins.py", line 188, in dry_or
    return func()
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 956, in <lambda>
    self.plugin.dry_or(lambda: tx_element.commit())
  File "/usr/lib/python2.7/site-packages/ovirt/node/setup/vdsm/engine_page.py", line 392, in commit
    raise Exception(msg)
Exception: Cannot register the node into 10.66.10.238!
Connection refused to 10.66.10.238
Full log: /var/log/vdsm/register.log
2015-12-02 02:27:16,798       INFO Changes were merged successfully
</snip>

#/vdsm/register.log
<snip>
2/02/2015 01:54:32 AM Received the following attributes:
12/02/2015 01:54:32 AM Engine FQDN: 10.66.10.238
12/02/2015 01:54:32 AM Engine URL: https://10.66.10.238:443
12/02/2015 01:54:32 AM Engine https port: 443
12/02/2015 01:54:32 AM Check FQDN: False
12/02/2015 01:54:32 AM Fingerprint: None
12/02/2015 01:54:32 AM Node address: None
12/02/2015 01:54:32 AM Node name: localhost
12/02/2015 01:54:32 AM SSH User: root
12/02/2015 01:54:32 AM SSH Port: 22
12/02/2015 01:54:32 AM VDSM Port: 54321
12/02/2015 01:54:32 AM VDSM UUID: None
12/02/2015 01:54:32 AM Engine CA: /etc/pki/ovirt-engine/ca.pem
12/02/2015 01:54:32 AM Starting registration...
12/02/2015 01:54:32 AM Get version via: https://10.66.10.238/ovirt-engine/services/host-register?version=1&command=get-version
12/02/2015 01:54:32 AM Cannot connect to engine. 10.66.10.238 matches the FQDN of Engine?
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/tool/register.py", line 476, in main
    reg.handshake()
  File "/usr/lib/python2.7/site-packages/vdsm/tool/register.py", line 138, in handshake
    res = requests.get(__GET_VERSION, verify=False)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 68, in get
    return request('get', url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 50, in request
    response = session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 464, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 576, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/adapters.py", line 415, in send
    raise ConnectionError(err, request=request)
ConnectionError: ('Connection aborted.', error(111, 'Connection refused'))
</snip>
     

So the bug is incomplete fixed, change bug status to ASSIGNED.
Comment 5 Fabian Deutsch 2015-12-02 05:27:54 EST
Yileye, please verify your setup

1. it is a different bug then what has been described before: ConnectionError: ('Connection aborted.', error(111, 'Connection refused'))
2. This error indicates that the host could not reach engine, please check your setup
Comment 6 yileye 2015-12-03 00:33:07 EST
I can reproduce this bug on ovirt-node-plugin-vdsm-0.6.1-1.el7ev.noarch

Test version:
rhev-hypervisor7-7.2-20151201.2
ovirt-node-plugin-vdsm-0.6.1-4.el7ev.noarch

Steps to Reproduce:
 1. TUI clean install rhev-hypervisor7-7-7.2-20150928.0 successful with no error.
 2. IN ‘Network‘ Page,Enable NIC via DHCP.
 3. In ‘Engine’ page ,Input an invalid Engine FQDN  address 
 4. Click ‘Save’.

Test result:
after step4,it not shows an error "list index out of range".

So the bug is fixed, change bug status to VERIFIED.
Comment 9 errata-xmlrpc 2016-03-09 09:41:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.