Bug 127222 - Error in I830WaitLpRing with Intel 82865G Graphics
Error in I830WaitLpRing with Intel 82865G Graphics
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-04 14:57 EDT by Howard Holm
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 13:22:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log from problem (50.93 KB, text/plain)
2004-07-04 14:58 EDT, Howard Holm
no flags Details
X configuration (2.99 KB, text/plain)
2004-07-04 14:59 EDT, Howard Holm
no flags Details

  None (edit)
Description Howard Holm 2004-07-04 14:57:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
On a Dell Dimension 8600 with the i865G chipset with integrated
graphics, the graphic display initially refused to start at anything
but 640x480 resolution.  I discovered
http://www.chzsoft.com.ar/855patch.html which solved the problem
somewhat, but after updating to BIOS A10 (released 29 June) the patch
no longer seemed necessary.  I noticed a dramatic improvement in
tuxracer speed after the BIOS update, although there are significant
screen artifacts while playing tuxracer (but not in anything else I've
noticed.)  When leaving the machine on for long periods (overnight)
the X window system crashes with the following error and doesn't seem
to be restartable (it encounters the same error) without a reboot.

Error in I830WaitLpRing(), now is 5799, start is 3798
pgetbl_ctl: 0x3ffe0001 pgetbl_err: 0x29
ipeir: 0 iphdr: 7f1403f7
LP ring tail: 38 head: 0 len: 1f001 start 0
eir: 0 esr: 10 emr: ffff
instdone: 68c1 instpm: 0
memmode: 108 instps: 53
hwstam: ffff ier: 0 imr: ffff iir: 0
space: 131008 wanted 131064
 
FatalError re-entered, aborting
lockup


Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Sometimes

Steps to Reproduce:
1. Leave machine on for long periods without use
2.
3.
    

Additional info:
Comment 1 Howard Holm 2004-07-04 14:58:39 EDT
Created attachment 101620 [details]
X log from problem
Comment 2 Howard Holm 2004-07-04 14:59:35 EDT
Created attachment 101621 [details]
X configuration
Comment 3 Howard Holm 2004-07-18 17:33:13 EDT
This failure is happening on some xscreensavers.  I've been able to
reproduce it at will with boxed.  Knowing that, it seems this is a
duplicate of 119705 which is incorrectly marked closed (It is not
fixed by the kernel stated there, or it's rebroken in later kernels.)
 Either way, it's not closed in rawhide.
Comment 4 Alex Cheng 2004-08-04 11:34:23 EDT
I'm having the same problem with the same videocard on an IBM Machine
S50 Intel865G Video Card.  It happens even with use sometimes.  The
taskbar just froze and unable to respond also.  
Comment 5 Steven Lawrance 2004-08-18 16:33:06 EDT
I'm experiencing the same thing occasionally on my box as well. It's
an old Dell GX110 with an Intel Corp. 82810E DC-133 CGC video controller.

The Xorg.0.log file ends with the following. I may be able to help out
with this issue, though I don't know very much about the internals of
x.org's source code. It would be nice to know what's causing it.

Error in I810WaitLpRing(), now is 5609568, start is 5607567
pgetbl_ctl: 0x1fcd0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 50c00004
LP ring tail: f598 head: f0c8 len: f001 start 580000
eir: 0 esr: 0 emr: 3d
instdone: ff3a instpm: 0
memmode: 4 instps: 810
hwstam: 9ac7 ier: 0 imr: 9ac7 iir: 0
space: 64296 wanted 65528
                                                                     
          
Fatal server error:
lockup
                                                                     
          
                                                                     
          
Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional
information.
                                                                     
          
Error in I810WaitLpRing(), now is 5611647, start is 5609646
pgetbl_ctl: 0x1fcd0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 50c00004
LP ring tail: f5a0 head: f0c8 len: f001 start 580000
eir: 0 esr: 0 emr: 3d
instdone: ff3a instpm: 0
memmode: 4 instps: 810
hwstam: 9ac7 ier: 0 imr: 9ac7 iir: 0
space: 64288 wanted 65528
                                                                     
          
FatalError re-entered, aborting
lockup
Comment 6 Mike A. Harris 2004-08-31 13:22:59 EDT
The Intel driver included in rawhide currently, which is from
X.Org 6.8.0RC3 (6.7.99.903), is much newer than the one included
in FC2.  Also, a brand new kernel DRM driver (i915) for Intel video
is now in our rawhide kernel.  The new DRM replaces the i830 kernel
module, and supports all Intel hardware from i830 upward.

Please test install Fedora Core 3 test1 and update to current
rawhide packages, or alternatively you can wait for Fedora Core 3
test2 to be released and upgrade to that.  It's also possible to
upgrade the kernel, xorg-x11 and some other packages on top of
Fedora Core 2, however that's more experimental and may not work
smoothly.

Once this problem has been tested with the current rawhide kernel
and X packages via one of the methods above, if the problem persists
still, please file a bug report in X.Org bugzilla so the Intel
video driver maintainers are aware of the problem and can investigate
if a solution is possible, or if it is a BIOS related bug.  X.Org
bugzilla is located at:  http://bugs.freedesktop.org in the "xorg"
component.  If you file a report there, we will track the issue
upstream for you as well, if you paste the bug URL here.

Thanks for testing Fedora development.

Note You need to log in before you can comment on or make changes to this bug.