Bug 1272222 - [BACKPORT] --installpkgs argument from lorax 22.1-1
[BACKPORT] --installpkgs argument from lorax 22.1-1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lorax (Show other bugs)
7.1
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 15:33 EDT by Pat Riehecky
Modified: 2016-11-03 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: lorax-19.6.67-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:44:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pat Riehecky 2015-10-15 15:33:19 EDT
Description of problem:
Adding packages to the lorax images currently requires editing the template files or building your own template directory.  Upstream lorax has added a --includepkg argument for this use case.

Version-Release number of selected component (if applicable): 	lorax-19.6.51-1.el7


How reproducible:100%


Steps to Reproduce:
1.look for option to pass additional packages via command line
2.
3.

Actual results:
No such option

Expected results:
commandline override for package set

Additional info:
git log 52d962d613886121aa2b8f52562fddb714f7dd9f

commit 52d962d613886121aa2b8f52562fddb714f7dd9f
Author: Colin Walters <walters@verbum.org>
Date:   Tue Nov 25 22:30:11 2014 -0500

    Add --includepkg argument
    
    Recently, Fedora has been trying to do a 3 product split.  As part of
    that, lorax was changed to do "installpkg lorax-product-*" via
    provides.
    
    I think that approach is awkward; a much simpler approach is to simply
    specify the product package as input to lorax on the command line, via
    external rel-eng scripts.
    
    This patch therefore adds --includepkg (and we should probably add an
    option to remove the implicit lorax-product-* glob).
Comment 2 Brian Lane 2015-10-16 20:48:19 EDT
It is actually named --installpkgs, the commit message is incorrect (because I missed updating it when I changed the name)
Comment 4 Peter Kotvan 2016-08-17 07:08:02 EDT
Verified on RHEL-7.3-20160811.0 with lorax-19.6.77-1.el7.
Comment 6 errata-xmlrpc 2016-11-03 19:44:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2165.html

Note You need to log in before you can comment on or make changes to this bug.