Bug 127225 - Segmentation Fault, strlen() from e_gethostbyname_r (libeutil.so.0)
Segmentation Fault, strlen() from e_gethostbyname_r (libeutil.so.0)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-04 15:52 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 13:02:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-07-04 15:52:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 91151280 (LWP 9484)]
0x00300ae3 in strlen () from /lib/tls/libc.so.6
(gdb) info stack
#0  0x00300ae3 in strlen () from /lib/tls/libc.so.6
#1  0x0015c9c8 in e_gethostbyname_r ()
   from /usr/lib/evolution/1.5/libeutil.so.0
#2  0x00e7f157 in camel_service_query_auth_types ()
   from /usr/lib/evolution/1.5/libcamel.so.0
#3  0x0079508d in start_thread () from /lib/tls/libpthread.so.0
#4  0x0036443a in clone () from /lib/tls/libc.so.6


Version-Release number of selected component (if applicable):
evolution-1.5.9.2-1

How reproducible:
Sometimes

Steps to Reproduce:
Send/Receive mail

Additional info:
Comment 1 Dave Malcolm 2004-07-06 20:47:30 EDT
It looks like the initial addrinfo returned from getaddrinfo has a
NULL ai_canonname

Looks similar to (though not a duplicate of) this bug; perhaps needs
some more bulletproofing in e_gethostbyname_r:
http://bugzilla.ximian.com/show_bug.cgi?id=56337 




Comment 2 Ivan Gyurdiev 2004-07-06 22:22:05 EDT
Yes, but my hosts are valid and should resolve.
Hmm, perhaps it isn't even evolution's fault.
Lately I've had lots of apps crash, and I can't figure out why...
mostly  fedora.us and livna, but not always. Mplayer crashes, xine
crashes, plaympeg crashes (but mpg123 works), some of the games I
wanted to look at crashed (enigma, supertux)... and now evolution. The
Nvidia 3D driver (the new one) doesn't work either.

Then the backtraces don't show anything meaningful - single entry with
question marks in it. 

Something is seriously wrong with FC right now, but I can't figure out
what it is exactly. It worked fine a week ago. I even reverted glibc
to FC2 from devel but that didn't help. 

Maybe something to do with the compiler - I don't know... hmm
Comment 3 Ivan Gyurdiev 2004-07-20 23:34:24 EDT
This still crashes with evolution evolution-1.5.90-5
and it's the most annoying thing ever. It's reproducible 70% of the
time. I have to retry about 10 times before being able to fetch my
mail. It always crashes on get/retrieve whether automatic or
user-triggered. The first time it asks to restart the application. The
second time it just dies. On the bright side I am happy with the mail
recover feature, which is nice to restore my in-progress email every
time evol. crashes due to auto-mail-fetch every 10 mins ( I refuse to
turn it off! )

no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 87571376 (LWP 5001)]
0x078bc1a6 in e_gethostbyname_r () from
/usr/lib/evolution/1.5/libeutil.so.0
(gdb) bt
#0  0x078bc1a6 in e_gethostbyname_r ()
   from /usr/lib/evolution/1.5/libeutil.so.0
(gdb)

Comment 4 Ivan Gyurdiev 2004-08-01 18:55:34 EDT
evolution-1.5.91-1

Still broken. I don't think FC3 should be released before this bug is
fixed. Evolution is a core application, and with this bug it's
practically unusable unless you're willing to put up with 20 crashes
to get your mail. 

Comment 5 Ivan Gyurdiev 2004-08-16 00:48:18 EDT
evolution-1.5.92.2-2

Still broken.
Comment 6 Ivan Gyurdiev 2004-08-23 13:02:23 EDT
Can no longer reproduce. 


Note You need to log in before you can comment on or make changes to this bug.