Bug 1272327 - cleanallruv should completely clean changelog
cleanallruv should completely clean changelog
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.7
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
: ZStream
Depends On: 1270002
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 02:38 EDT by Jan Kurik
Modified: 2015-12-15 08:31 EST (History)
13 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-66.el6_7
Doc Type: Bug Fix
Doc Text:
Previously, after the cleanAllRUV task finished, the change log still contained entries from the cleaned Replica ID. As a consequence, the replica update vector (RUV) could contain undesirable data, and the RUV element could be missing the replica URL. Now, cleanAllRUV cleans the change log completely as expected.
Story Points: ---
Clone Of: 1270002
Environment:
Last Closed: 2015-12-15 08:31:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-10-16 02:38:28 EDT
This bug has been copied from bug #1270002 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 4 Sankar Ramalingam 2015-11-26 10:07:14 EST
Verification steps: https://bugzilla.redhat.com/show_bug.cgi?id=1240845#c6
Comment 5 Sankar Ramalingam 2015-12-02 01:26:42 EST
1. Six master replication setup.
2. Stopped M4 and cleaned replication agreement from M1.
3. Ran cleanallruv task for M4
4. Killed M1 and started again.
5. Ran ldapsearch to check if M4's ruv is still shown for M1.

[root@iceman ~]# ldapsearch -x -p 1189 -h localhost -D "cn=Directory Manager" -w Secret123 -b "cn=1189_to_1626_on_iceman.idmqe.lab.eng.bos.redhat.com,cn=replica,cn=\"dc=passsync,dc=com\",cn=mapping tree,cn=config"
---
nsDS5ReplicaCredentials: {DES}2mO8LgMr/w5ognn2BRK+gQ==
nsds50ruv: {replicageneration} 565de5cb000004cf0000
nsds50ruv: {replica 1232 ldap://iceman.idmqe.lab.eng.bos.redhat.com:1289}
nsds50ruv: {replica 1231 ldap://iceman.idmqe.lab.eng.bos.redhat.com:1189} 565d
 e842000004cf0000 565de846000804cf0000
nsds50ruv: {replica 2231 ldap://iceman.idmqe.lab.eng.bos.redhat.com:2189}
nsds50ruv: {replica 2332 ldap://iceman.idmqe.lab.eng.bos.redhat.com:3289}
nsds50ruv: {replica 2331 ldap://iceman.idmqe.lab.eng.bos.redhat.com:3189}
nsds50ruv: {replica 2232 ldap://iceman.idmqe.lab.eng.bos.redhat.com:2289}


[root@iceman ~]# /usr/sbin/stop-dirsrv M4
Stopping instance "M4"

[root@iceman ~]# ldapdelete -x -p 1189 -h localhost -D "cn=Directory Manager" -w Secret123 "cn=1189_to_2626_on_iceman.idmqe.lab.eng.bos.redhat.com,cn=replica,cn=\"dc=passsync,dc=com\",cn=mapping tree,cn=config"

[root@iceman ~]# cat /export/cleanruv.ldif 
dn: cn=M4clean,cn=cleanallruv,cn=tasks,cn=config
cn: M4clean
objectclass: extensibleObject
replica-base-dn: dc=passsync,dc=com
replica-id: 2232
[root@iceman ~]# ps -eaf |grep -i slapd |grep M1
dsuser    8655     1  0 00:36 ?        00:00:01 /usr/sbin/ns-slapd -D /etc/dirsrv/slapd-M1 -i /var/run/dirsrv/slapd-M1.pid -w /var/run/dirsrv/slapd-M1.startpid

[root@iceman ~]# kill -9 8655

[root@iceman ~]# /usr/sbin/start-dirsrv M1
Starting instance "M1"

[root@iceman ~]# ldapsearch -x -LLL -p 1189 -h localhost -D "cn=Directory Manager" -w Secret123 -b "dc=passsync,dc=com" '(&(nsuniqueid=ffffffff-ffffffff-ffffffff-ffffffff)(objectclass=nstombstone))' nsds50ruv
dn: nsuniqueid=ffffffff-ffffffff-ffffffff-ffffffff,dc=passsync,dc=com
nsds50ruv: {replicageneration} 565de5cb000004cf0000
nsds50ruv: {replica 1231 ldap://iceman.idmqe.lab.eng.bos.redhat.com:1189} 565d
 e842000004cf0000 565de846000804cf0000
nsds50ruv: {replica 2332 ldap://iceman.idmqe.lab.eng.bos.redhat.com:3289}
nsds50ruv: {replica 2331 ldap://iceman.idmqe.lab.eng.bos.redhat.com:3189}
nsds50ruv: {replica 1232 ldap://iceman.idmqe.lab.eng.bos.redhat.com:1289}

Build tested:
[root@iceman ~]# rpm -qa |grep -i 389-ds-base
389-ds-base-devel-1.2.11.15-67.el6_7.x86_64
389-ds-base-1.2.11.15-67.el6_7.x86_64
389-ds-base-libs-1.2.11.15-67.el6_7.x86_64
389-ds-base-debuginfo-1.2.11.15-67.el6_7.x86_64
Comment 7 errata-xmlrpc 2015-12-15 08:31:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2640.html

Note You need to log in before you can comment on or make changes to this bug.