Bug 1272339 - Creating a already deleted snapshot-clone deletes the corresponding snapshot.
Creating a already deleted snapshot-clone deletes the corresponding snapshot.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Avra Sengupta
:
Depends On: 1271627 1273703
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 03:16 EDT by Avra Sengupta
Modified: 2016-06-16 09:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1271627
Environment:
Last Closed: 2016-06-16 09:40:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avra Sengupta 2015-10-16 03:16:55 EDT
+++ This bug was initially created as a clone of Bug #1271627 +++

Description of problem:

Deleting and then creating the snapshot-clone with the same name deletes the snapshot as well


Version-Release number of selected component (if applicable):

glusterfs-3.7.5-0.19


How reproducible:
Always


Steps to Reproduce:
1. Create a dist-replica volume and start it.
2. Create a snapshot of this volume.
3. Create a clone from this snapshot.
4. Delete the clone and observe that the clone entries can still be seen under /run/gluster/snaps/clonename/../ and its is shows as mounted.
5. Create the clone again with the same name from the snapshot.
6. Observe that the creation of clone fails and inturn it deletes the snapshot from which we are trying to create the clone.

Actual results:

Creating a already deleted clone deletes the corresponding snapshot.

Expected results:

Failure while creating a clone should not delete the corresponding snapshot.

Additional info:

logs attached for the reference

--- Additional comment from Vijay Bellur on 2015-10-15 06:46:30 EDT ---

REVIEW: http://review.gluster.org/12364 (snapshot: Fix snapshot clone postvalidate) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-15 06:52:45 EDT ---

REVIEW: http://review.gluster.org/12364 (snapshot: Fix snapshot clone postvalidate) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 1 Vijay Bellur 2015-10-16 03:18:30 EDT
REVIEW: http://review.gluster.org/12364 (snapshot: Fix snapshot clone postvalidate) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2015-10-16 06:15:24 EDT
REVIEW: http://review.gluster.org/12364 (snapshot: Fix snapshot clone postvalidate) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 3 Vijay Bellur 2015-10-20 06:00:15 EDT
COMMIT: http://review.gluster.org/12364 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 59401a32de51cdb6c1a5a1208723e89e1a4abd30
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu Oct 15 16:08:03 2015 +0530

    snapshot: Fix snapshot clone postvalidate
    
    In glusterd_snapshot_clone_postvalidate(), we were deleting
    snap object and snap vol, by looking up snapname. Hence, it
    was deleting the orignal snapshot from which the clone was
    being created
    
    Instead it should fetch the clonename, the respective
    clone vol, and its corresponding snap object, and delete them.
    
    Also glusterd_snap_remove(), needs to differentiate a clone
    snap object from a snaphsot snap object, as in case of a clone
    snap object, we don't have any persisted data in
    /var/run/gluster/snaps/ and hence is shouldn't try to delete
    anything there.
    
    Change-Id: I02bb22a3898d5720e318a02d6cc32d25f75d317d
    BUG: 1272339
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/12364
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:40:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.