Bug 1272348 - ksc crashes when run without arguments
Summary: ksc crashes when run without arguments
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ksc (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: Unspecified Linux
unspecified
medium
Target Milestone: rc
: 7.3
Assignee: Stanislav Kozina
QA Contact: Chunyu Hu
Marie Dolezelova
URL:
Whiteboard:
Keywords: Rebase
: 1318914 (view as bug list)
Depends On:
Blocks: 1318914 1370477
TreeView+ depends on / blocked
 
Reported: 2015-10-16 07:47 UTC by Akemi Yagi
Modified: 2016-11-04 03:54 UTC (History)
6 users (show)

Fixed In Version: ksc-0.9.15-1.el7.noarch
Doc Type: Release Note
Doc Text:
*ksc* now returns an error instead of crashing when running without mandatory arguments Previously, the *ksc* tool terminated unexpectedly when running without the mandatory arguments. With this update, *ksc* returns an error message and exits gracefully in the described situation.
Story Points: ---
Clone Of:
: 1318914 (view as bug list)
Environment:
Last Closed: 2016-11-04 03:54:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add rheh67 to ksc (700 bytes, patch)
2015-10-16 07:49 UTC, Akemi Yagi
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2334 normal SHIPPED_LIVE ksc bug fix update 2016-11-03 13:45:02 UTC

Description Akemi Yagi 2015-10-16 07:47:29 UTC
Description of problem:
When ksc is run on a RHEL 6.7 system, it produces the following error:

Traceback (most recent call last):
  File "/usr/share/ksc/ksc.py", line 449, in <module>
    k.main()
  File "/usr/share/ksc/ksc.py", line 130, in main
    self.releasedir = choices['rhel{0}'.format(get_release_name())]
KeyError: 'rhel6.7'

Version-Release number of selected component (if applicable):
ksc-0.9.14-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Run ksc on RHEL 6.7
2.
3.

Actual results:
See above

Expected results:
No error

Additional info:

Comment 1 Akemi Yagi 2015-10-16 07:49 UTC
Created attachment 1083531 [details]
Patch to add rheh67 to ksc

Comment 2 Akemi Yagi 2015-10-16 07:50:16 UTC
A patch submitted.

Comment 4 Stanislav Kozina 2016-04-28 09:41:29 UTC
Akemi,

Thank you for your report. This happens with ksc version 0.9.14 on both rhel-6 and rhel-7. I'm fixing this in upcoming release of ksc-0.9.15.

Comment 5 Stanislav Kozina 2016-04-28 09:44:47 UTC
*** Bug 1318914 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2016-11-04 03:54:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2334.html


Note You need to log in before you can comment on or make changes to this bug.