Bug 127235 - System clock running slow (at half speed roughly)
System clock running slow (at half speed roughly)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-04 22:03 EDT by Bojan Smojver
Modified: 2015-01-04 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-12 05:55:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2004-07-04 22:03:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.16

Description of problem:
The system clock runs behind (roughly half speed) when acpi=on is used
on this hardware (HP Pavillion ZE4201 notebook). Regular clock (tsc)
and pit do the same thing. However, if I pass clock=pmtmr on the
kernel boot command line, the problem goes away.

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435.2.3

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel with acpi=on and observe time.

Actual Results:  The system time is behind.

Expected Results:  The system time should be correct.

Additional info:

Workaround with clock=pmtmr. Maybe related to this bug:
http://bugme.osdl.org/show_bug.cgi?id=2375.
Comment 1 Barry K. Nathan 2004-07-14 04:51:44 EDT
If you try a kernel from one of the following sources, does the
problem still occur?

+ rawhide (a.k.a. FC-devel)
+ FC 3 test 1
+ http://people.redhat.com/arjanv/2.6/

(To the best of my knowledge, these kernels have the fix for OSDL bug
2375.)
Comment 2 Laurent ARMAND 2004-09-21 18:07:21 EDT
Hi,

I have the same problem with FC2 Kernel 2.6.8-1.521.
The machine is a HP Pavilion ze4232s.
T try with kernel 2.6.5-1.358 and there is no problem.

If fact clock works correctly about 10 seconds and then, after theses
10 sec, 1 sec= 2 real seconds !

If you run a big program, clock is going to run correctly 10 seconds
more and after return in 1 sec= 2 real sec.
 
Comment 3 Bojan Smojver 2004-10-13 22:31:32 EDT
In relation to kernel bug:

http://bugzilla.kernel.org/show_bug.cgi?id=2375

it seems to be that it was actually directly opposite there. The PM
timer, according to that bug report, ran twice as fast. What I'm
seeing is that TSC timer runs at half speed and PM timer runs OK.

In other words, I doubt that this kernel bug is actually a fix for
that problem. Also, problem still exists in as late as 2.6.8-1.607
kernel (which is actually 2.6.9-rc4 based).
Comment 4 Bojan Smojver 2004-10-14 07:42:55 EDT
Something funky is going on with clocks in recent Linux kernels. Here
is a kernel bug for a different notebook that talks about the same issues:

http://bugzilla.kernel.org/show_bug.cgi?id=3243
Comment 5 Bojan Smojver 2004-12-20 19:06:47 EST
I have another system, based on K6, which uses i586 kernel
(kernel-2.6.9-1.681_FC3). This kernel says that TSC cannot be used as
time source and pmtmr and pit give the clock at half the speed.

So, this particular box cannot AT ALL keep good time. Most definitely
a bug.
Comment 6 Bojan Smojver 2005-01-04 05:24:41 EST
I can see this behavior with kernel-2.6.10-1.1063_FC4 installed on
Fedora Core 3. The message in dmesg says:

----------------------------
PM-Timer running at invalid rate: 200% of normal - aborting.
Warning: clock= override failed. Defaulting to PIT
----------------------------

when I try clock=pmtmr option in the kernel line. TSC doesn't work at all.

Is there a way to tell the kernel to use PMTMR although it thinks that
it's running too fast? It is obvious that it is PIT that doesn't run
as it should...
Comment 7 Bojan Smojver 2005-01-12 05:55:11 EST
This is completely ACPI related. This particular motherboard, which is
very old, has pretty crummy ACPI support. Once ACPI is turned off, the
clock works fine.

Note You need to log in before you can comment on or make changes to this bug.