Bug 1272361 - Unclear location of directories for product.img and updates.img creation
Unclear location of directories for product.img and updates.img creation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lorax (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks: 1256306
  Show dependency treegraph
 
Reported: 2015-10-16 04:41 EDT by Jan Stodola
Modified: 2017-02-09 03:56 EST (History)
1 user (show)

See Also:
Fixed In Version: lorax-19.6.67-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:44:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2015-10-16 04:41:39 EDT
Description of problem:

/usr/share/doc/lorax-<version>/README.product says:

Lorax now supports creation of product.img and updates.img as part of the build
process. This is implemented using the installimg command which will take the
contents of a directory and create a compressed archive from it. The x86, ppc,
ppc64le and aarch64 templates all look for /usr/share/lorax/product/ and
/usr/share/lorax/updates/ directories while creating the final install tree. If
there are files in those directories lorax will create images/product.img
and/or images/updates.img
...

From this description it's not clear whether /usr/share/lorax/product/ and /usr/share/lorax/updates/ are directories on the file system where lorax is running from, or directories in lorax installroot (the second is correct, see bug 1244330 comment 11)

Please, make it more clear.

Version-Release number of selected component (if applicable):
lorax-19.6.66-1.el7
Comment 2 Brian Lane 2015-12-02 16:25:28 EST
Patch will be https://github.com/rhinstaller/lorax/pull/73 applied to the correct file on rhel7-branch
Comment 4 Michal Kovarik 2016-08-11 08:26:43 EDT
Verified on lorax-19.6.76-1.el7. Documentation is updated by patch from comment 2.
Comment 6 errata-xmlrpc 2016-11-03 19:44:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2165.html

Note You need to log in before you can comment on or make changes to this bug.