Bug 1272384 - Received hangup when doing live external disk-only snapshot with sanlock on qemu-kvm
Received hangup when doing live external disk-only snapshot with sanlock on q...
Status: CLOSED DUPLICATE of bug 1191901
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.2
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 06:07 EDT by yangyang
Modified: 2015-11-26 15:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 15:21:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yangyang 2015-10-16 06:07:23 EDT
Description of problem:
Received hangup when doing live external disk-only snapshot with sanlock on qemu-kvm

Version-Release number of selected component (if applicable):
libvirt-1.2.17-13.el7.x86_64
qemu-kvm-1.5.3-104.el7.x86_64
sanlock-3.2.4-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Enable sanlock
#setsebool virt_use_sanlock 1
#setsebool sanlock_use_nfs 1

Edit the conf file
# grep "lock_manager" /etc/libvirt/qemu.conf
lock_manager = "sanlock"

# vim /etc/libvirt/qemu-sanlock.conf


auto_disk_leases = 1
disk_lease_dir = "/var/lib/libvirt/sanlock"
host_id = 1
user = "sanlock"
group = "sanlock"

Then configure sanlock

# echo 'SANLOCKOPTS="-w 0"' > /etc/sysconfig/sanlock

# service sanlock start
# service libvirtd restart

2. start a vm
#virsh dumxpml vm1
<disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/var/lib/libvirt/images/rhel7.2.qcow2'/>
      <backingStore/>
      <target dev='vda' bus='virtio'/>
      <boot order='1'/>
      <alias name='virtio-disk0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>
    </disk>

# virsh start vm1
Domain vm1 started

# ll /var/lib/libvirt/sanlock/
total 2048
-rw-------. 1 sanlock sanlock 1048576 Oct 14 15:05 c3cf7234e0624c13f6054c91bbcfca14
-rw-r-----. 1 sanlock sanlock 1048576 Oct 14 15:05 __LIBVIRT__DISKS__

3. create live external disk only snapshot
# virsh snapshot-create-as vm1 s1 --disk-only
2015-10-14 07:07:58.743+0000: 9980: info : libvirt version: 1.2.17, package: 13.el7 (Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>, 2015-10-08-09:11:06, x86-035.build.eng.bos.redhat.com)
2015-10-14 07:07:58.743+0000: 9980: warning : virKeepAliveTimerInternal:143 : No response from client 0x7fc9816e47c0 after 6 keepalive messages in 35 seconds
2015-10-14 07:07:58.743+0000: 9979: warning : virKeepAliveTimerInternal:143 : No response from client 0x7fc9816e47c0 after 6 keepalive messages in 35 seconds
error: internal error: received hangup / error event on socket

Actual results:
Step 3 received hangup

Expected results:
Step 3 should report that live disk snapshot not supported with this QEMU binary

Additional info:
Comment 2 Jaroslav Suchanek 2015-11-26 15:21:18 EST

*** This bug has been marked as a duplicate of bug 1191901 ***

Note You need to log in before you can comment on or make changes to this bug.