Bug 127239 - ncurses isn't polling current TERMINFO db
ncurses isn't polling current TERMINFO db
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 00:28 EDT by chris crowell
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-06 12:32:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris crowell 2004-07-05 00:28:14 EDT
Description of problem: Building htop-0.3.3-1, upon run, display is
completely degraded (can only see some of the processes, can't see any
of the proc info by scrolling right).

Version-Release number of selected component (if applicable):
ncurses-5.4-5

How reproducible:
Every time, regardless of console type.

Steps to Reproduce:
1. Download and build htop (htop.sourceforge.net).
2. Run app in terminal (window manager doesn't make a difference).
3.
  
Actual results: Displays only about half of what it did on FC1.


Expected results: Full display and refresh.


Additional info: After troubleshooting with project creator, found
that setting TERM=xterm-color corrects display. Rebuilding ncurses
from source also fixes problem. I've installed from several different
repositories, with the same degraded results. ncurses-5.4-5 rpm needs
to be rebuilt and redistributed I'm guessing.
Comment 1 Thomas E. Dickey 2004-07-05 18:35:11 EDT
What does infocmp show?
And what terminal emulator?
(Presumably gnome-terminal, but not stated).
htop 3.3 works fine on my Debian/testing in uxterm.
Comment 2 chris crowell 2004-07-05 20:56:00 EDT
The problem is not with ncurses per se, rather with Fedora Core 2's
main rpm repositories.

Tested on gnome-terminal, konsole, xterm & uxterm, at which point it
seemed ubiquitous and I didn't worry about rxvt or eterm.

A simple rebuild of ncurses src rpm did the trick.

First few lines of infocmp on FC2 gnome-terminal:
------------------
#       Reconstructed via infocmp from file: /usr/share/terminfo/x/xterm
xterm|xterm terminal emulator (X Window System),
        am, bce, km, mir, msgr, xenl,
        colors#8, cols#80, it#8, lines#24, pairs#64,
        acsc=``aaffggiijjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~,
------------------

I have been running htop on Debian (Sarge & Woody), Libranet 2.8.1,
Knoppix, DSL 0.3.7, ArchLinux, Mepis, RHE 3, RH 9, Fedora Core 1, and
Slackware 9.x & 10 without any problems, but as I say, there's nothing
wrong with ncuses, just FC2's i386 base rpm build of it. Sorry to not
have been more informative.
Comment 3 Eido Inoue 2004-07-06 12:32:44 EDT
Rebuilt htop 0.3.3 on FC2 with latest ncurses-- can't seem to find
anything wrong with it. As it seems to work on the latest
ncurses-5.4-5 from yum, marking as fixed in current release.
Comment 4 chris crowell 2004-07-06 12:43:18 EDT
Great Adrian, sorry for the trouble. You can view the old screen shot
here: http://fury.techell.com/htop033_xterm.png Puzzling, must have
been a personal problem on my end. Thanks again.
Comment 5 Eido Inoue 2004-07-06 12:51:30 EDT
There's an annoying little home/end problem fix that will go in the
build today, which will revert (sigh) yet again the terminfo custom
defs for red hat, so this will need to be retested... but i will make
sure that htop is one of the apps that behave well with the new change.
Comment 6 Thomas E. Dickey 2004-07-06 13:10:42 EDT
Changing terminfo entries is slow work.  I spent about a day in
the past week working on the new entries for xterm, only to find
that I'll have to work around some bugs in screen (3.09.13) that
I'd forgotten.

Note You need to log in before you can comment on or make changes to this bug.