Bug 1272402 - Able to create duplicate heat templates with the same name
Able to create duplicate heat templates with the same name
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.5.0
Assigned To: Dan Clarizio
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 06:36 EDT by Aziza Karol
Modified: 2015-11-11 15:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 11:08:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
duplicate entries (85.73 KB, image/png)
2015-10-16 06:36 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-10-16 06:36:36 EDT
Created attachment 1083554 [details]
duplicate entries

Description of problem:


Version-Release number of selected component (if applicable):
5.4.3.1

How reproducible:
100%

Steps to Reproduce:
1.Navigate to services->catalogs->templates
2.Add a heat template and save
3.again add the heat template with the same name

Actual results:
heat templates with the same name can  be added.see attached screenshot

Expected results:
validation required

Additional info:
Comment 2 Bill Wei 2015-10-21 11:08:07 EDT
Template name does not need to be unique because they can come from different provider. 
The uniqueness is by the content.
So this BZ can be closed as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.