Bug 127245 - /etc/printcap.local is ignored
/etc/printcap.local is ignored
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-printer (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 02:26 EDT by Philip Hirschhorn
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.6.102-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-05 06:14:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Hirschhorn 2004-07-05 02:26:11 EDT
Description of problem:
/etc/printcap.local is supposed to be included into /etc/printcap, but
it isn't.  This is true both with the distributed version of
/etc/printcap.local (which consists only of comments) and also after I
added a printer description to it.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.79.5-1
cups-1.1.19-13

How reproducible:
Every time you start up cups.

Steps to Reproduce:
1.  Kill cups.
2.  Start cups.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2004-07-05 05:19:21 EDT
The print spooler is no longer driven by /etc/printcap -- it is there
for informational purposes, to be used by legacy applications that
might read it.  CUPS writes /etc/printcap based on its own configuration.
Comment 2 Miloslav Trmac 2004-07-05 05:58:48 EDT
Wouldn't it make sense not to ship the file at all, then?
Comment 3 Tim Waugh 2004-07-05 06:07:31 EDT
Oops.  Thought it was something you'd created, sorry.
Comment 4 Tim Waugh 2004-07-05 06:14:48 EDT
Fixed in system-config-printer-0.6.102-1.
Comment 5 Philip Hirschhorn 2004-07-05 19:44:47 EDT
Thanks!

Any chance there'll be a fix I can install in Fedora Core 1?
Comment 6 Tim Waugh 2004-07-06 04:30:14 EDT
No, it's not a big enough change to warrant that -- you can get the
same effect by 'rm /etc/printcap.local'.
Comment 7 Philip Hirschhorn 2004-07-06 13:05:38 EDT
I think you're misunderstanding the function of /etc/printcap.local: I
have (or at least had, using RedHat 7.3 and many earlier versions) a
hand-edited print filter, and I wanted to create a print queue that
used that filter instead of the ones offered by cups.  I put the
following into /etc/printcap.local:

magic|magicfilter:\
        :ml=0:\
        :mx=0:\
        :sd=/var/spool/lpd/magicfilter:\
        :af=/var/spool/lpd/magicfilter/magicfilter.acct:\
        :sh:\
        :lp=/dev/lp0:\
        :lpd_bounce=true:\
        :if=/usr/local/bin/ljet4-filter:

(where /usr/local/bin/ljet4-filter was a hand-edited version of the
filter produced by the (now allegedly obsolete) magicfilter version
1.2).  After I created the appropriate spool directory, I could then
use this to print.  (In fact, I then had the default print queue
forward print jobs on to this queue, so this was effectively the default.)

This isn't vital, since I have other (slightly less convenient) ways
of accomplishing most of what I want to do, but /etc/printcap.local
*does* allow you to do things that I at least haven't figured out how
to do using cups directly.
Comment 8 Tim Waugh 2004-07-06 18:04:51 EDT
See comment #1 -- this is no longer possible, and hasn't been since
the switch to CUPS.  You must configure CUPS directly.

Note You need to log in before you can comment on or make changes to this bug.