Bug 1272457 - rapid-photo-downloader Version: 0.4.10 Release: 3.fc23 does not download fotos
Summary: rapid-photo-downloader Version: 0.4.10 Release: 3.fc23 does not download fotos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rapid-photo-downloader
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-16 12:49 UTC by joerg.lechner
Modified: 2015-12-18 10:00 UTC (History)
2 users (show)

Fixed In Version: rapid-photo-downloader-0.4.11-1.fc23 rapid-photo-downloader-0.4.11-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-18 07:54:51 UTC


Attachments (Terms of Use)
test result rapid photo downloader Version: 0.4.10 Release: 3.fc23 (162.49 KB, image/png)
2015-10-16 12:49 UTC, joerg.lechner
no flags Details

Description joerg.lechner 2015-10-16 12:49:28 UTC
Created attachment 1083643 [details]
test result rapid photo downloader Version: 0.4.10 Release: 3.fc23

Description of problem: Installed rapid-photo-downloader in F23 Final x86_64 desktop (TC6 and TC9 same behaviour). No preview of photos, no photo download


Version-Release number of selected component (if applicable):
Version: 0.4.10 Release: 3.fc23

How reproducible:
always

Steps to Reproduce:
1. plug in foto flash card
2. start rapid-photo-downloader
3.

Actual results:
no preview of photos, no download

Expected results:
preview and download

Additional info:

Comment 1 Damon Lynch 2015-10-22 12:50:23 UTC
Fixed in upstream version 0.4.11: https://launchpad.net/rapid/trunk/0.4.11/+download/rapid-photo-downloader-0.4.11.tar.gz

Comment 2 Fedora Update System 2015-10-23 08:08:53 UTC
rapid-photo-downloader-0.4.11-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0fe64ea936

Comment 3 Fedora Update System 2015-10-23 08:32:34 UTC
rapid-photo-downloader-0.4.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-184fda689c

Comment 4 joerg.lechner 2015-10-23 12:24:15 UTC
installation of F23 Final Desktop x86_64, updates,
installation of rapid-photo-downloader-0.4.11-1.fc23.noarch.rpm
from bodhi 

[joerg@linux ~]$ rapid-photo-downloader
Traceback (most recent call last):
  File "/usr/bin/rapid-photo-downloader", line 3, in <module>
    import rapid.rapid
  File "/usr/lib/python2.7/site-packages/rapid/rapid.py", line 25, in <module>
    import dbus
ImportError: No module named dbus
[joerg@linux ~]$

Test result: not possible to start, something missing in my F23 installation? or rapid-photo-downloader?

Comment 5 joerg.lechner 2015-10-23 14:51:35 UTC
F22
downloaded and installed rapid-photo-downloader.noarch 0.4.11-1.fc22 from koji.
seems to be a bit slower then the versiom 4.10, but for me it's ok, download of photos (1345) ok.

Comment 6 Fedora Update System 2015-10-24 12:06:13 UTC
rapid-photo-downloader-0.4.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rapid-photo-downloader'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0fe64ea936

Comment 7 joerg.lechner 2015-10-24 14:03:58 UTC
tested, not possible to start application -> error, see log

[joerg@localhost Downloads]$ dnf info rapid-photo-downloader
Last metadata expiration check performed 0:19:12 ago on Sat Oct 24 15:42:04 2015.
Installierte Pakete
Name        : rapid-photo-downloader
Arch        : noarch
Epoch       : 0
Version     : 0.4.11
Release     : 1.fc23
Größe       : 2.5 M
Paketquelle : @System
Aus Paketqu : @commandline
Zusammenfas : Images downloader for external devices
URL         : http://damonlynch.net/rapid/
Lizenz      : GPLv2+
Beschreibun : Rapid Photo Downloader is written by a photographer for
            : professional and amateur photographers. It can download photos
            : from multiple memory cards and Portable Storage Devices
            : simultaneously. It provides a variety of options for sub-folder
            : creation, image renaming and backup. It does not download images
            : directly from a camera unless the camera is recognized as an
            : external drive.

[joerg@localhost Downloads]$ dnf info dbus
Last metadata expiration check performed 0:19:28 ago on Sat Oct 24 15:42:04 2015.
Installierte Pakete
Name        : dbus
Arch        : x86_64
Epoch       : 1
Version     : 1.10.0
Release     : 1.fc23
Größe       : 567 k
Paketquelle : @System
Aus Paketqu : koji-override-0
Zusammenfas : D-BUS message bus
URL         : http://www.freedesktop.org/Software/dbus/
Lizenz      : (GPLv2+ or AFL) and GPLv2+
Beschreibun : D-BUS is a system for sending messages between applications. It is
            : used both for the system-wide message bus service, and as a
            : per-user-login-session messaging facility.

Verfügbare Pakete
Name        : dbus
Arch        : i686
Epoch       : 1
Version     : 1.10.0
Release     : 1.fc23
Größe       : 247 k
Paketquelle : fedora
Zusammenfas : D-BUS message bus
URL         : http://www.freedesktop.org/Software/dbus/
Lizenz      : (GPLv2+ or AFL) and GPLv2+
Beschreibun : D-BUS is a system for sending messages between applications. It is
            : used both for the system-wide message bus service, and as a
            : per-user-login-session messaging facility.

[joerg@localhost Downloads]$ rapid-photo-downloader --debug
Traceback (most recent call last):
  File "/usr/bin/rapid-photo-downloader", line 3, in <module>
    import rapid.rapid
  File "/usr/lib/python2.7/site-packages/rapid/rapid.py", line 25, in <module>
    import dbus
ImportError: No module named dbus
[joerg@localhost Downloads]$

Comment 8 Fedora Update System 2015-10-26 18:27:59 UTC
rapid-photo-downloader-0.4.11-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rapid-photo-downloader'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-184fda689c

Comment 9 Fedora Update System 2015-12-18 07:54:49 UTC
rapid-photo-downloader-0.4.11-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-12-18 10:00:07 UTC
rapid-photo-downloader-0.4.11-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.