Bug 1272491 - [WebUI] Certificate action dropdown does not display all the options after adding new certificate
Summary: [WebUI] Certificate action dropdown does not display all the options after ad...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: 1263764
TreeView+ depends on / blocked
 
Reported: 2015-10-16 14:27 UTC by Varun Mylaraiah
Modified: 2016-11-04 05:39 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:39:00 UTC


Attachments (Terms of Use)
Host certificate (358.67 KB, image/png)
2015-10-16 14:31 UTC, Varun Mylaraiah
no flags Details
Verified on ipa-server-4.4.0-12.el7.x86_64 (66.44 KB, image/png)
2016-09-19 11:58 UTC, Varun Mylaraiah
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC
Red Hat Bugzilla 1263764 None None None Never

Internal Trackers: 1263764

Description Varun Mylaraiah 2015-10-16 14:27:00 UTC
Description of problem:
Certificate action dropdown does not display all the options after adding new certificate

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-13.el7.x86_64

How reproducible:
100%

 In Host page, After adding certificate following option are not displayed : 
View Certificate
Get Certificate
Revoke Certificate
Restore Certificate


Actual results:
I have attached screenshots, please have a look. 

PS
-However able to see show button in host "certificate section" after adding the certificate. 
-Not sure if it is the latest implementation 

Expected results:


Additional info:

Comment 1 Varun Mylaraiah 2015-10-16 14:31 UTC
Created attachment 1083699 [details]
Host certificate

Comment 4 Petr Vobornik 2015-10-19 18:31:46 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5381

Comment 11 Petr Vobornik 2016-06-29 13:47:43 UTC
The certificate UI was completely redesigned.

It is possible to:
- add user certs
- display multiple certs on user/host/service details page
- display/download/revoke/remove hold/delete each individual cert on the details page.

Comment 13 Varun Mylaraiah 2016-09-19 11:58 UTC
Created attachment 1202460 [details]
Verified on ipa-server-4.4.0-12.el7.x86_64

Comment 15 errata-xmlrpc 2016-11-04 05:39:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.