Bug 127252 - ntpd init.d script should work correctly with -T
ntpd init.d script should work correctly with -T
Status: CLOSED DUPLICATE of bug 168220
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ntp (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Raszyk
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 06:22 EDT by James Ralston
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 03:40:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for ntpd init.d script (1.01 KB, patch)
2004-07-05 06:26 EDT, James Ralston
no flags Details | Diff

  None (edit)
Description James Ralston 2004-07-05 06:22:21 EDT
The ntpd init.d script makes these assumptions:

ntpconf=/etc/ntp.conf
ntpstep=/etc/ntp/step-tickers

These assumptions will be wrong if the -T option was specified in
OPTIONS in /etc/sysconfig/ntpd, because $ntpconf and $ntpstep will
then be relative to the chroot() jail.

Version-Release number of selected component (if applicable):

ntp-4.1.2-4.EL3.1
Comment 1 James Ralston 2004-07-05 06:26:36 EDT
Created attachment 101635 [details]
patch for ntpd init.d script

This patch makes the ntpd init.d script smart enough to locate $ntpconf and
$ntpstep correctly, even if -T was specified.
Comment 3 Petr Raszyk 2005-09-20 03:40:53 EDT
 This is a bug in ntpd documentation (launch at the command
 prompt "man ntpd").
 Right flag (to chroot the ntpd server process into chroot_dir)
 is '-i' not '-T'.
 The flag '-T' is really used only by NTP simulator engine
 (created by Harish Nair, University of Delaware, 2001) and
 does something different than '-i' (than chroot into chrootdir).
 The binary distribution does not contain this simulation.
 The flag '-T' should not be documented in man-pages at all.

 We make change in man-pages. Correct ntpd-man-page could be:
---------------------------------------------------------------
ntpd(1)                                             ntpd(1)

NAME
       ntpd - Network Time Protocol (NTP) daemon

SYNOPSIS
       ntpd  [  -aAbdgLmNPqx  ] [ -c conffile  ] [ -f driftfile  ]
             [ -g ] [ -k keyfile  ] [ -l logfile  ] [ -N high ] 
             [ -p pidfile  ] [ -r  broadcast-delay  ] 
             [ -s statsdir  ] [ -t key  ] [ -v variable  ] 
             [ -V variable  ] [ -i chroot_dir  ] 
             [ -u server_user  ] [ -x ]

...
...
...

  -i      chroot_dir  Chroot  the ntpd server process into
          chroot_dir. To use this option you have to copy all
          the files that  ntpd  process needs into the chroot
          directory. This option adds security only if the
          server also drops root privileges (see -u  option).

---------------------------------------------------------------

This bug is duplicate of #168220

*** This bug has been marked as a duplicate of 168220 ***

Note You need to log in before you can comment on or make changes to this bug.