Bug 127254 - sdl resolution switching is broken
sdl resolution switching is broken
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Depends On:
  Show dependency treegraph
Reported: 2004-07-05 06:50 EDT by Kurt Erickson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-07-09 11:21:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg.conf file (2.27 KB, text/plain)
2004-07-05 06:53 EDT, Kurt Erickson
no flags Details
patch to fix sdl 1.2.7 x11modes on ppc (435 bytes, patch)
2004-07-09 09:52 EDT, Kurt Erickson
no flags Details | Diff
binary rpm with patch applied; for convenience of users 'til fix migrates to rawhide (204.89 KB, application/octet-stream)
2004-07-09 09:57 EDT, Kurt Erickson
no flags Details

  None (edit)
Description Kurt Erickson 2004-07-05 06:50:00 EDT
Description of problem:

SDL resolution switching doesn't work.

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. Open chromium (or any other sdl app)
2. Switch to fullscreen.
Actual results:

Game has a large black border, instead of switching to fullscreen.

Expected results:

Game switches resolutions.

Additional info:

I have installed debian on this same machine and didn't have this
problem, so I know that it's not hardware. This is a known bug in ppc
sdl, with a patch available. See this post for more info:


The patch is:

-#if defined(__alpha__) || defined(__sparc64__) || defined(__powerpc__)
+#if defined(__alpha__) || defined(__sparc64__)

I can't verify that it works. I do know that working sdl fullscreen
resolution switching is possible under ppc, as debian currently has
it. Someone should investigate this, it's a serious bug.
Comment 1 Kurt Erickson 2004-07-05 06:53:03 EDT
Created attachment 101636 [details]
xorg.conf file

This this my xorg.conf file. I have tried this same file under debian, renamed
to XF86Config-4, and sdl resolution switching still worked. So I am confident
that it is not an xorg configuration problem.
Comment 2 Kurt Erickson 2004-07-09 09:52:57 EDT
Created attachment 101746 [details]
patch to fix sdl 1.2.7 x11modes on ppc

OK, I made a patch, applyed it to SDL-1.2.7-6.src.rpm (from rawhide) and
rebuilt the rpm. I can confirm that it works, bug is fixed with no bad effects!
Patch and rpm are attached; would someone please alert the SDL maintainer, I'd
like to see this patch in rawhide asac.
Comment 3 Kurt Erickson 2004-07-09 09:57:01 EDT
Created attachment 101747 [details]
binary rpm with patch applied; for convenience of users 'til fix migrates to rawhide
Comment 4 Thomas Woerner 2004-07-09 11:21:37 EDT
Fixed in rawhide in rpm  or newer.

Note You need to log in before you can comment on or make changes to this bug.