Bug 1272545 - Trouble creating a document with TOC on RHS and multiple HTML pages, with each chapter and major section on a separate pages.
Trouble creating a document with TOC on RHS and multiple HTML pages, with eac...
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 13:11 EDT by Cheryl Fernandes
Modified: 2015-10-18 18:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-18 18:39:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cheryl Fernandes 2015-10-16 13:11:37 EDT
Description of problem:
I am trying to create an HTML document with a TOC on the RHS and multiple HTML pages, with each chapter and major section on a separate page.

Version-Release number of selected component (if applicable):
I am using Publican 3.2

How reproducible:
Easily reproducible


Steps to Reproduce:
1. Create a document. 'publican create --name testdocument'
2. Build it to produce the TOC on the RHS  'publican build --formats=html-desktop --langs=en-US'
3. If you open the html page, you can see the TOC on the RHS and all content is on a single HTML page.

Actual results:
Since I'm using html-desktop, Publican outputs the document as a single HTML page with the table of contents located in a separate pane on the left side of the document. 

Expected results:
I want the TOC to be present on the RHS but the content to be displayed in multiple HTML pages, with each chapter and major section on a separate pages like it displays when I build with option 'html'.

Additional info:
Can I get this done if I create a website instead of a document?
Comment 1 Jeff Fearn 2015-10-18 18:39:13 EDT
(In reply to Cheryl Fernandes from comment #0)
> Description of problem:
> I am trying to create an HTML document with a TOC on the RHS and multiple
> HTML pages, with each chapter and major section on a separate page.

You can't get this without creating a brand and customising the output.

What I'd recommend is using DocBook5 & html output and then in your brand modify the css so that the TOC, which is at the bottom as a pop-up, is displayed on the RHS and not a pop-up.

Note You need to log in before you can comment on or make changes to this bug.