This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1272553 - rhel-osp-director: The deployed nodes are dropped into dracut shell on VM setup installed with export TESTENV_ARGS="--baremetal-bridge-names 'brbm brbm1 brbm2 brbm3 brbm4 brbm5'" , eth0 and eth1 both get 192.0.2.X IP.
rhel-osp-director: The deployed nodes are dropped into dracut shell on VM set...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity urgent
: async
: 7.0 (Kilo)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 13:57 EDT by Alexander Chuzhoy
Modified: 2015-11-19 18:30 EST (History)
8 users (show)

See Also:
Fixed In Version: openstack-ironic-2015.1.1-6.el7ost
Doc Type: Bug Fix
Doc Text:
Prior to this update, Ironic generated an iSCSI target name that violated RFC 3720 and 3721, and was therefore incompatible with tools that expect a properly constructed name. With this update, Ironic generates a name that complies with these RFCs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:30:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rdsosreport (238.35 KB, text/plain)
2015-10-19 10:34 EDT, Alexander Chuzhoy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1459243 None None None Never
OpenStack gerrit 186014 None None None Never

  None (edit)
Description Alexander Chuzhoy 2015-10-16 13:57:45 EDT
rhel-osp-director: The deployed nodes are dropped into dracut shell with rhel-7.2-test-images.


Environment:

instack-0.0.7-2.el7ost.noarch
instack-undercloud-2.1.2-30.el7ost.noarch
rhel-7.2-test-images built on 15/Oct.

Starting the overcloud deployment with openstack overcloud deploy --templates



Result:
The deployment gets stack.
The deployed overcloud nodes are dropped into dracut shell.
Comment 2 Mike Burns 2015-10-16 15:53:22 EDT
Adding Lucas and Dmitry.  This happens both with pre-built and environment-built images.
Comment 4 Dmitry Tantsur 2015-10-19 05:10:28 EDT
Hi! I'll look into it, could you please grab /run/initramfs/rdsosreport.txt from the failed node?
Comment 7 Mike Burns 2015-10-19 07:31:55 EDT
Note:  also reproduced on both baremetal and virt
Comment 8 Alexander Chuzhoy 2015-10-19 10:34 EDT
Created attachment 1084427 [details]
rdsosreport
Comment 9 Dmitry Tantsur 2015-10-19 12:11:24 EDT
Relevant logs:

[   11.292169] localhost dracut-pre-mount[373]: //iscsi-func@10(start_iscsi_target): /targetcli-wrapper /backstores/block create block1 dev=/dev/sda
[   11.296171] localhost dracut-pre-mount[373]: /targetcli-wrapper:17: UserWarning: 'rtslib' package name for rtslib-fb is deprecated, please instead import 'rtslib_fb'
[   11.298232] localhost dracut-pre-mount[373]: import rtslib
[   11.302160] localhost dracut-pre-mount[373]: //iscsi-func@11(start_iscsi_target): /targetcli-wrapper /iscsi create iqn-45703554-61b3-452a-b04e-85eb71b0bb80
[   11.304820] localhost dracut-pre-mount[373]: /targetcli-wrapper:17: UserWarning: 'rtslib' package name for rtslib-fb is deprecated, please instead import 'rtslib_fb'
[   11.307175] localhost dracut-pre-mount[373]: import rtslib
[   11.341720] localhost dracut-pre-mount[373]: WWN not valid as: iqn, naa, eui
[   11.351543] localhost dracut-pre-mount[373]: //iscsi-func@12(start_iscsi_target): /targetcli-wrapper /iscsi/iqn-45703554-61b3-452a-b04e-85eb71b0bb80/tpg1/luns create /backstores/block/block1 1
[   11.365137] localhost dracut-pre-mount[373]: /targetcli-wrapper:17: UserWarning: 'rtslib' package name for rtslib-fb is deprecated, please instead import 'rtslib_fb'
[   11.366345] localhost dracut-pre-mount[373]: import rtslib
[   11.469649] localhost dracut-pre-mount[373]: No such path /iscsi/iqn-45703554-61b3-452a-b04e-85eb71b0bb80

Seems like something has changed around targetcli. Does anyone know if it got updated recently?
Comment 10 Dmitry Tantsur 2015-10-19 13:07:18 EDT
Hmm, let me clarify one more thing: we're talking about deploy *process*, not already deployed images, right? The heading is a bit misleading, I assumed at first that user images do not start.
Comment 11 Dmitry Tantsur 2015-10-20 08:35:45 EDT
Anyway, my guess is that we should backport https://github.com/openstack/ironic/commit/accc67443e06c840e90f26318f57bc3f5a11fa8b
Comment 12 Dmitry Tantsur 2015-10-20 08:39:02 EDT
Please apply patch https://code.engineering.redhat.com/gerrit/#/c/59773/ to ironic and let me know if it works.
Comment 13 Alexander Chuzhoy 2015-10-23 11:30:44 EDT
Tried to update:
openstack-ironic-api              
openstack-ironic-common                             
openstack-ironic-conductor
from:
the https://brewweb.devel.redhat.com/taskinfo?taskID=9991496

right before the introspection.

The introspected nodes went into dracut...
Comment 14 Dmitry Tantsur 2015-10-23 12:54:53 EDT
Please resend the logs (from the ramdisk and from ironic conductor), I'd like do know what it is now.
Comment 15 Alexander Chuzhoy 2015-10-23 14:49:30 EDT
So it seems like there's a bug with instack-virt-setup.

If I export:
export TESTENV_ARGS="--baremetal-bridge-names 'brbm brbm1 brbm2 brbm3 brbm4 brbm5'"
prior to running instack-virt-setup, then eth0 and eth1 on the introspected nodes end up on the provisioning network.


If no network isolation is expected (and thus only brbm exists) - the nodes are introspected with no issue.
Comment 16 Alexander Chuzhoy 2015-10-23 16:31:28 EDT
OK, so this BZ seems like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1234601
Comment 20 nlevinki 2015-11-19 02:18:44 EST
deployment passed and we run full automation.
no issues were found
Comment 22 errata-xmlrpc 2015-11-19 18:30:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2496

Note You need to log in before you can comment on or make changes to this bug.