Bug 1272599 - Oracle connection profile type does not support service name [NEEDINFO]
Oracle connection profile type does not support service name
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling, Teiid (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Barry LaFond
Matus Makovy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 16:40 EDT by Cojan van Ballegooijen
Modified: 2015-12-07 12:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:24:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vhalbert: needinfo? (blafond)


Attachments (Terms of Use)
Connection Profile Wizard screen shot (1.18 MB, image/png)
2015-10-16 16:40 EDT, Cojan van Ballegooijen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2232 Major Open Cannot create JDBC/Oracle connection profile using ServiceName syntax 2016-04-19 11:59 EDT

  None (edit)
Description Cojan van Ballegooijen 2015-10-16 16:40:11 EDT
Created attachment 1083809 [details]
Connection Profile Wizard screen shot

Description of problem:
When you create a new connection profile with an Oracle driver in my case 11 the connection url format is jdbc:oracle:thin:@server:1521:db

Version-Release number of selected component (if applicable):
9.0.3.Final

How reproducible:
See below

Steps to Reproduce:
1. Create a new Teiid Model Project
2. File->Import 
3. JDBC database >> Source Model
4. Click button New at the Connection Profile Dropdown box
5. Select Oracle as Connection Profile Type
6. Click button Add new driver at the Drivers Dropdown box
7. In the properties screen one can only use a SID 

Actual results:
N/A

Expected results:
Way to be able to use service name in the connection url

Additional info:
Workaround is to use the Generic JDBC driver but people might make mistakes since the default translator will be Generic jdbc instead of Oracle.
Comment 2 Cojan van Ballegooijen 2015-10-16 16:43:29 EDT
See also https://issues.jboss.org/browse/TEIIDDES-2232
Comment 3 Barry LaFond 2015-11-03 12:10:43 EST
The Oracle Connection profile wizard is an Eclipse plugin.  Designer has no control over how that URL is constructed.
Comment 4 Van Halbert 2015-11-03 12:25:23 EST
Can we get this BZ moved over to where ever handles the connection profiles?
Comment 6 Barry LaFond 2015-12-07 12:24:12 EST
Now using only JIRA... closing.

Note You need to log in before you can comment on or make changes to this bug.