Bug 1272609 - python-six fails 1.9.0-1 to -2 update on egg-info [NEEDINFO]
python-six fails 1.9.0-1 to -2 update on egg-info
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-six (Show other bugs)
6.7
noarch Linux
unspecified Severity medium
: rc
: ---
Assigned To: Python Maintainers
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 17:41 EDT by Justin Ryan
Modified: 2016-08-31 03:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 03:35:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pviktori: needinfo? (justin)


Attachments (Terms of Use)

  None (edit)
Description Justin Ryan 2015-10-16 17:41:02 EDT
Description of problem:

The python-six-1.9.0-2.el6 release replaced an egg-info directory with an egg-info file, which rpm's cpio refuses to do.

$ repoquery -l python-six-1.9.0-1.el6 |grep egg
/usr/lib/python2.6/site-packages/six-1.9.0-py2.6.egg-info
/usr/lib/python2.6/site-packages/six-1.9.0-py2.6.egg-info/PKG-INFO
/usr/lib/python2.6/site-packages/six-1.9.0-py2.6.egg-info/SOURCES.txt
/usr/lib/python2.6/site-packages/six-1.9.0-py2.6.egg-info/dependency_links.txt
/usr/lib/python2.6/site-packages/six-1.9.0-py2.6.egg-info/top_level.txt
$ repoquery -l python-six-1.9.0-2.el6 |grep egg
/usr/lib/python2.6/site-packages/six-1.9.0-py2.6.egg-info

Version-Release number of selected component (if applicable):

1.9.0-2.el6

How reproducible:

Always

Steps to Reproduce:

$ rpm -q python-six
python-six-1.9.0-1.el6.noarch
$ rpm -U python-six-1.9.0-2.el6.noarch.rpm 
error: unpacking of archive failed on file /usr/lib/python2.6/site-packages/six-1.9.0-py2.6.egg-info: cpio: rename failed - Is a directory

Actual results:

$ ls -ld /usr/lib/python2.6/site-packages/six* |grep egg
drwxr-xr-x. 2 root root    86 Oct 16 21:34 /usr/lib/python2.6/site-packages/six-1.9.0-py2.6.egg-info
----------. 1 root root  1419 Oct 16 21:34 /usr/lib/python2.6/site-packages/six-1.9.0-py2.6.egg-info;56216d81

Expected results:

Package should continue to provide egg-info as a directory, or force overwrite the directory with the new file
Comment 2 Robert Kuska 2015-12-09 05:22:51 EST
This is caused by python-six-1.9.0-2.el6 not using setuptools to build a package.

Where does python-six-1.9.0-1.el6 come from if I may ask?
Comment 3 Honza Horak 2016-08-31 03:35:14 EDT
No response from reporter, so closing.

Note You need to log in before you can comment on or make changes to this bug.