Bug 1272619 - 4.2.3-200 breaks AR9462 Wireless Network Adapter
4.2.3-200 breaks AR9462 Wireless Network Adapter
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 19:13 EDT by Mike Romberg
Modified: 2015-10-29 11:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 11:53:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Romberg 2015-10-16 19:13:11 EDT
Description of problem:

  After a dnf update that included both firmware updates (may not be related) and a kernel upgrade to 4.2.3-200 (from 4.1.10-200) the dual band wireless
card (listed below) fails to connect to the wireless router.

  Relevant section of lspci:

07:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)

  Using the same hardware with windows 8 works fine.  Also booting the older kernel (4.1.10) works as well.  So, I'm assuming something changed in the kernel between 4.1.10 and 4.2.3.

Version-Release number of selected component (if applicable):

  kernel 4.1.10  (good)
  kernel 4.2.3   (wifi fails to connect)

How reproducible:

  Used the kde UI for Network manager.

Steps to Reproduce:
1.  boot to 4.2.3 and try to connect to a wireless AP
    Note that the access points are visible.  You just can't connect to them.
2.  Fails

Actual results:
  Fail to connect

Expected results:

  Authenticate and connect

Additional info:

  I am willing do dig deeper into this if needed.  At the moment I'm fairly convinced something regressed in the kernel.
Comment 1 Mike Romberg 2015-10-29 11:53:49 EDT
Turns out that this was NetworkManager not dealing well with
the 4.1 -> 4.2 kernel changes.  While the bad symptoms did track
with the above mentioned kernels it went away with a NetworkManager
update.  So, fixed (for now)...

Note You need to log in before you can comment on or make changes to this bug.