Bug 1272621 - unable to install ceph-radosgw specific to 1.2.3 from CDN
unable to install ceph-radosgw specific to 1.2.3 from CDN
Status: CLOSED NOTABUG
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Unclassified (Show other bugs)
1.2.3
x86_64 Linux
unspecified Severity high
: rc
: 1.3.2
Assigned To: ceph-eng-bugs
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 20:00 EDT by Tamil
Modified: 2015-10-19 17:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 17:44:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results from attempting to start ceph-radosgw on RHEL 7.0 (1.19 KB, text/plain)
2015-10-16 21:51 EDT, Warren
no flags Details

  None (edit)
Description Tamil 2015-10-16 20:00:35 EDT
Description of problem:

when using subscription manager to grab the ceph-radosgw package from rhel-7-server-rh-common-rpms repo, it always pulls the latest package available in there which is ceph-radosgw-0.80.8-17, while the one that is relevant to 1.2.3 is ceph-radosgw-0.80.8-5. This happens because there is not a way right now to specify in the repo which package version has to be installed.

we need to do make a way to be able to install specific versions of ceph-radosgw from CDN like 1.2.3, 1.2.3-1, 1.2.3-2.


Version-Release number of selected component (if applicable):
1.2.3

How reproducible:
always

Steps to Reproduce:
using the subscription-manager steps to pull the ceph-radosgw package by enabling the repo for rhel-7-server-rh-common-rpms

Actual results:
it always installs ceph-radosgw-0.80.8-17

Expected results:
it should install ceph-radosgw-0.80.8-5

Additional info:
This issue seems to happen only now, since we have many packages under the same repo [all the 1.2.3-1 and 1.2.3-2 versions of ceph-radosgw], which was not the case before where there was only 1.2.3
Comment 2 Warren 2015-10-16 21:51 EDT
Created attachment 1083846 [details]
Results from attempting to start ceph-radosgw on RHEL 7.0
Comment 3 Warren 2015-10-16 22:03:22 EDT
One more odd note -- the subscription manager seems to prefer that I run as qa@redhat.com

When I run as wusui1@redhat.com, I get Invalid credential messages when I try
to enable repos.  It did allow me to login and attach the pool, however.
Comment 5 Ken Dreyer (Red Hat) 2015-10-19 10:38:49 EDT
It looks like we never shipped ceph-radosgw-0.80.8-5.el7cp to users, because it was subject to the socket path issue described in bz #1203518. So we bumped the Release value there for RH-COMMON, from -5 to -6. Since RGW doesn't ship on the 1.2.3 ISO, and this was the only difference between -5 and -6, there was no point to re-spinning the 1.2.3 ISO just for this change.

It's not clear to me why you would want to install the GA version of "1.2.3" instead of "1.2.3 plus all the async fixes" today, but if you really want to install what we shipped as "1.2.3", you can install the earliest ceph-radosgw package in RH-COMMON, 0.80.8-6.
Comment 6 Tamil 2015-10-19 17:44:32 EDT
we needed this to verify 1.2.3 upgrades from rhel 7.1 to rhel 7.2. we dont ideally test upgrades for new OS with point releases [like 1.2.3-1 or 1.2.3-2]

All i wanted to know was, if someone did want to install ceph-radosgw for 1.2.3, how do they even know which version of it is on the CDN. I was originally expecting ceph-radosgw version to be v0.80.8-5 as the ceph-common package version for 1.2.3 is v0.80.8-5. it was my guess.

but yes, I do realise, customers or anyone else [unlike QE] may not have a need to install 1.2.3 right now.

and yes, I tried installing specific version of ceph-radosgw from CDN after enabling the repo "rhel-7-server-rh-common-rpms" and it worked fine.

Thanks. I will go ahead and close this bug.

Note You need to log in before you can comment on or make changes to this bug.