Bug 1272633 - video.use_native_backlight=1 doesn't work (except for kernel 4.0/4.1)
video.use_native_backlight=1 doesn't work (except for kernel 4.0/4.1)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 21:58 EDT by Neil
Modified: 2015-10-26 10:24 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 10:24:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg after boot into kernel 4.2 (62.72 KB, text/plain)
2015-10-16 22:02 EDT, Neil
no flags Details
dmesg after boot into kernel 4.1 (61.72 KB, text/plain)
2015-10-16 22:06 EDT, Neil
no flags Details
Dell XPS14 DMI info (531 bytes, text/plain)
2015-10-22 07:42 EDT, Alessandro Guido
no flags Details

  None (edit)
Description Neil 2015-10-16 21:58:30 EDT
video.use_native_backlight=1 or acpi_backlight=vendor boot parameter doesn't work at all after upgrade kernel. 


When booting kernel 4.2 my screen works the same with or without the parameter.


It works perfect in kernel kernel-4.1.10-200.fc22.x86_64
Comment 1 Neil 2015-10-16 22:02 EDT
Created attachment 1083847 [details]
dmesg after boot into kernel 4.2
Comment 2 Neil 2015-10-16 22:06 EDT
Created attachment 1083848 [details]
dmesg after boot into kernel 4.1
Comment 3 Neil 2015-10-21 00:24:33 EDT
I can't reproduce this bug neither with kernel-4.0.4-301.fc22.x86_64
Comment 4 Neil 2015-10-21 01:20:31 EDT
bug also present in kernel-4.3.0-0.rc6.git0.1.fc24.x86_64
Comment 5 Josh Boyer 2015-10-21 09:02:43 EDT
The use_native_backlight parameter was removed from the kernel with version 4.2 (via commit 3bd6bce).  You should be able to specify acpi_backlight=native on the newer kernels.

What kind of laptop is this though, and what results are you looking to achieve with the backlight parameter?
Comment 6 Neil 2015-10-21 10:45:39 EDT
Thanks! I suspected that the parameter was replaced again, sorry for not searching enough.


Lenovo G470, It'll work OK with even with kernel 2.6.x I think. But since I replaced my screen, I'm only able to switch brightness from min to max, only these two levels, I tried everything even installing Windows 7, and 10, I reflashed my bios etc, nothing worked (the brightness slider on windows acts like there's at least 10 levels of brightness, brightness change to max only after hit 50%< in the menu for example) , it seems to be an ACPI issue, I thought that it was fixable on Fedora since Fedora at least detected only two levels of brightness (you can only go from 1% (?) to 10%), I noticed that if I put the old screen back, and putting it back the new one, brightness will work fine with the new one lol, Lenovo Support told me that it was my motherboard, and it had to be replaced, I acquire this laptop in 2012~, I have no warranty anymore. Fortunately, I can fix this easily with one single parameter at least on Linux.

(sorry for any typos, this is not my native language)
Comment 7 Alessandro Guido 2015-10-22 03:40:30 EDT
Since I've been bitten by this change too, I'll leave a note for other users lurking around. On my Dell XPS14 (L421X) the new working kernel parameter is:

    acpi_backlight=video

instead of the "video.use_native_backlight=0" used with kernel versions prior to 4.2
Comment 8 Hans de Goede 2015-10-22 04:22:03 EDT
Hi,

(In reply to Alessandro Guido from comment #7)
> Since I've been bitten by this change too, I'll leave a note for other users
> lurking around. On my Dell XPS14 (L421X) the new working kernel parameter is:
> 
>     acpi_backlight=video
> 
> instead of the "video.use_native_backlight=0" used with kernel versions
> prior to 4.2

So I take it that without that cmdline option your backlight misbehaves / you cannot control it ?

In that case we should add a dmi based quirk to the kernel for your model laptop to do this automatically, can you please do:

grep '.*' /sys/class/dmi/id/*_* 2> /dev/null > dmi.log

And attach dmi.log here.

Thanks.

Hans
Comment 9 Alessandro Guido 2015-10-22 07:41:44 EDT
(In reply to Hans de Goede from comment #8)
> So I take it that without that cmdline option your backlight misbehaves /
> you cannot control it ?

That's correct.

> In that case we should add a dmi based quirk to the kernel for your model
> laptop to do this automatically, can you please do:
> 
> grep '.*' /sys/class/dmi/id/*_* 2> /dev/null > dmi.log
> 
> And attach dmi.log here.
> 
> Thanks.
> 
> Hans

Done (I've removed uniquely identifying fields).

Thanks.
Comment 10 Alessandro Guido 2015-10-22 07:42 EDT
Created attachment 1085476 [details]
Dell XPS14 DMI info
Comment 11 Hans de Goede 2015-10-26 10:24:22 EDT
Hi,

(In reply to Alessandro Guido from comment #10)
> Created attachment 1085476 [details]
> Dell XPS14 DMI info

Thanks, I've submitted a patch upstream to automatically use acpi_backlight=video on this model XPS 14. Since you've been managing so far with the cmdline options, I think it is best to just wait for this to trickle down through the Fedora kernels via the stable tree.

(In reply to Duff Padmasana from comment #6)
> Lenovo G470, It'll work OK with even with kernel 2.6.x I think. But since I
> replaced my screen, I'm only able to switch brightness from min to max, only
> these two levels

Ah, so this is due to a hardware mod, nothing we can do from our side then, you just need to use the new variant of the kernel cmdline option.

Regards,

Hans

Note You need to log in before you can comment on or make changes to this bug.