Bug 1272651 - Buggy spinner in the top bar of gnome-shell when launching an application
Buggy spinner in the top bar of gnome-shell when launching an application
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-17 06:07 EDT by Sébastien Wilmet
Modified: 2015-10-20 17:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 17:38:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screencast of the buggy spinner (472.07 KB, application/octet-stream)
2015-10-17 06:18 EDT, Sébastien Wilmet
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 756888 None None None Never

  None (edit)
Description Sébastien Wilmet 2015-10-17 06:07:19 EDT
Description of problem:
When launching an application, sometimes a spinner appears in the top bar of gnome-shell, on the right of the application name. And that spinner doesn't spin correctly, it looks like the speed is way too fast, or has a wrong center or something (it's difficult to describe).

It'll be clearer with a screencast.

Version-Release number of selected component (if applicable):
* Fedora Workstation 23
* GNOME Classic with gnome-shell-3.18.0-1.fc23.x86_64

How reproducible:
Sometimes the spinner in the top bar isn't shown, instead the spinner is at the mouse cursor, in which case there is no problems. But when a spinner is shown in the top bar, then the bug occurs.

It can be easily reproducible when launching Firefox (which takes a long time to appear), but the bug can occur with other apps.

Actual results:
The spinner in the top bar is buggy.

Expected results:
The spinner in the top bar should be smooth. Or the spinner should be shown always at the mouse cursor, not in the top bar.

Additional info:
I use the i915 graphics driver.
Comment 1 Sébastien Wilmet 2015-10-17 06:18 EDT
Created attachment 1083901 [details]
Screencast of the buggy spinner

When recording the screencast it looks like it goes a bit slower, so it's easier to see that the arcs of the spinner are in the wrong direction.
Comment 2 Florian Müllner 2015-10-20 17:38:28 EDT
Gah, we fixed this for the normal session, but forgot about classic mode :-(

Moving upstream.

Note You need to log in before you can comment on or make changes to this bug.