Bug 1272653 - PC initiated move takes about 5 secs
PC initiated move takes about 5 secs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pychess (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bruno Wolff III
Fedora Extras Quality Assurance
:
Depends On: 924214
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-17 06:24 EDT by joerg.lechner
Modified: 2016-07-25 12:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-25 11:53:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pychess 0.12.1 is blocked (410.17 KB, image/png)
2015-10-30 07:31 EDT, joerg.lechner
no flags Details
saved Pychess 0.12.1 file after being blocked (433 bytes, application/x-chess-pgn)
2015-10-30 07:34 EDT, joerg.lechner
no flags Details
Pychess 12 cuts communication an stops: F24 or Pychess error (556 bytes, application/x-chess-pgn)
2016-07-05 10:59 EDT, joerg.lechner
no flags Details
Pychess 12 cuts communication an stops: F24 or Pychess error (119.65 KB, image/png)
2016-07-05 11:00 EDT, joerg.lechner
no flags Details

  None (edit)
Description joerg.lechner 2015-10-17 06:24:59 EDT
Description of problem: It takes about 5 secs before the does a move as an answer of the move of the chess player, recognized since F23 Final TC6, still present in TC9. In F22 the answer of a PC initiated move is immediately, not after about 5 secs.


Version-Release number of selected component (if applicable):
Version     : 0.10.1
Release     : 8.fc23


How reproducible:
always

Steps to Reproduce:
1. install pychess
2. play pychess
3.

Actual results:
 waiting time about 5 secs before pc does a pc initiated move

Expected results:
move immediately as in F22

Additional info:
Comment 1 joerg.lechner 2015-10-18 00:37:05 EDT
If it's wanted to wait about 5 secs before a PC initiated move is done, and if it's not a Python bug, in my feeling this waiting time is too long. About 2 secs are sufficient.
Comment 2 Bruno Wolff III 2015-10-18 12:42:07 EDT
pychess hasn't changed recently. I am not sure what changed. I wouldn't be too surprised if it is a python change prompting the problem. pychess 0.12 is up to rc5 now, so that might be worth looking at. I won't have time for that before the f23 release. I'll see if I can check if the python version change triggered the issue.
Comment 3 Bruno Wolff III 2015-10-18 13:38:10 EDT
I checked the upstream codebase and they aren't maintaining a 0.10 branch since 0.10.1, so we pretty much will need to go to 0.12 rcs to see if there is a pychess fix to the issue.
Comment 4 Bruno Wolff III 2015-10-27 12:34:39 EDT
pychess 0.12 has been released. I'll get rawhide updated to that release and see how things go.
Comment 5 joerg.lechner 2015-10-30 07:30:14 EDT
loaded pychess
Arch        : noarch
Epoch       : 0
Version     : 0.12
Release     : 1.py34
Größe       : 11 M

from URL         : http://pychess.org

to F23 Final RC10, worked good, but in a play suddenly blocked. See screenshot attachments.
This only for information, possibly this comment is misplaced, sorry.
Comment 6 joerg.lechner 2015-10-30 07:31 EDT
Created attachment 1087918 [details]
Pychess 0.12.1 is blocked
Comment 7 joerg.lechner 2015-10-30 07:34 EDT
Created attachment 1087919 [details]
saved Pychess 0.12.1 file after being blocked
Comment 8 Hans de Goede 2016-03-03 05:51:51 EST
I've just updated pychess for f24+ to 0.12.3, unfortunately that version still suffers from this bug.
Comment 9 Raphael Groner 2016-03-03 05:58:33 EST
Propably it's already known to upstream, please consult:
https://github.com/pychess/pychess/issues
Comment 10 Sergio Monteiro Basto 2016-03-03 12:08:43 EST
pychess 
/usr/lib/python2.7/site-packages/pychess/System/gstreamer.py:38: PyGIWarning: Gst was imported without specifying a version first. Use gi.require_version('Gst', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gst

I know that most probably is to be unrelated , but set Gst can improve something , I think.
Comment 11 Hans de Goede 2016-03-04 02:15:53 EST
Hi,

(In reply to Raphael Groner from comment #9)
> Propably it's already known to upstream, please consult:
> https://github.com/pychess/pychess/issues

There seems to be no issue reported upstream for this bug, it would be good if someone could report this upstream.

Regards,

Hans
Comment 12 Bajusz Tamás 2016-06-26 03:54:01 EDT
Pychess author here.

1. I can't understand this bug report. The move response time in any chess engine is depending from time control and engine strength settings. All engine  decides hes time used to calculate a move on its own. If you want faster responses you can chose shorter time control or lower the engine strength. On lower levels (you can chose 1-20 in pychess) most engines will search only limited depth, so they will move immediately. Pychess own engine is written in Python (it can calculate max 3-4 ply depth in reasonable time) so you have to chose strength 1 or 2. But if you install f.e. stockfish engine, it will move in 1-2 sec even on strength level 10 in a 5 min game.

There are 2 exceptions exist. In opening phase engines can use (configurable) opening book files to immediate response, and similarly they can use endgame table bases in 6 or less man positions.

2. As Bruno said 0.10.x line is not maintained anymore.

3. 0.12.1 can't be blocked on 2015-10-30 as it was released 2015-12-07. If you can produce any block with current (0.12.4) release, please report it upstream!

4. The Gst warning is fixed in 0.12.4 (maybe before).
Comment 13 Bruno Wolff III 2016-06-26 09:34:25 EDT
0.12.4 is building for rawhide and f24. Given 0.10 isn't supported, I plan to try to get 0.12.4 in f23 as well. I expect getting the new version is worth dealing with any switching costs. Most likely it will be in testing in about a day.
Comment 14 joerg.lechner 2016-06-26 13:26:51 EDT
retested now Pychess in F23:
Installierte Pakete
Name        : pychess
Arch        : noarch
Epoch       : 0
Version     : 0.10.1
Release     : 8.fc23
Größe       : 5.7 M
Paketquelle : @System
Aus Paketqu : fedora
Zusammenfas : Chess game for GNOME
URL         : http://pychess.org
Lizenz      : GPLv3
Beschreibun : PyChess is a GTK+ chess game for Linux. It is designed to at the
            : same time be easy to use, beautiful to look at, and provide
            : advanced functions for advanced players.

in F23 all is now ok. For me works.

F24 I could not test, there is a module missing, which Pychess needs to run.
Comment 15 joerg.lechner 2016-06-26 13:40:21 EDT
that's what I see currently in F24:
[joerg@linux ~]$ dnf info pychess
Fedora 24 - x86_64 - Updates                    5.8 MB/s | 5.3 MB     00:00    
Fedora 24 - x86_64                              6.0 MB/s |  47 MB     00:07    
Letzte Prüfung auf abgelaufene Metadaten: vor 0:00:16 am Sun Jun 26 19:33:40 2016.
Installierte Pakete
Name        : pychess
Arch        : noarch
Epoch       : 0
Version     : 0.12.3
Release     : 1.fc24
Größe       : 12 M
Paketquelle : @System
Aus Paketqu : fedora
Zusammenfas : Chess game for GNOME
URL         : http://pychess.org
Lizenz      : GPLv3
Beschreibun : PyChess is a GTK+ chess game for Linux. It is designed to at the
            : same time be easy to use, beautiful to look at, and provide
            : advanced functions for advanced players.

[joerg@linux ~]$ pychess
ERROR: PyChess requires pygobject to be installed.
[joerg@linux ~]$ 

I could not find pygobject in the "normal" libraries for F24
A blocking situation did not occur in my current tests. But I will use Pychess now more frequently again, if a blocking occurs again I will report.
Comment 16 Sergio Monteiro Basto 2016-06-26 14:28:58 EDT
The story of update in March of 2016 is here [1] (Fedora Games ML) 

[1] https://lists.fedoraproject.org/archives/list/games@lists.fedoraproject.org/thread/DGAONDIQGEIU557VZLD4OL27NTFQU2WW/

In the end I wrote : 
- I have to analyze better the bug (1272653) but in kde looks to me, ...

- I think we should also update F23 , because should be updated in F23 before F23 GA, it is a leaf package , and end users will get a better experience .


(In reply to joerg.lechner from comment #15)
> I could not find pygobject in the "normal" libraries for F24

https://apps.fedoraproject.org/packages/s/pygobject

we have pygobject2 and pygobject3
Comment 17 Bruno Wolff III 2016-06-26 18:58:33 EDT
0.12.4 has been built for rawhide, f24 and f23. It is in testing now on f24, and should hit testing soon for f23.
The missing pygobject would be a separate bug if it is still present in f24. I'll try a quick test to see if there is a missing requires and I just got lucky in my tests.
Comment 18 Bruno Wolff III 2016-06-26 19:01:47 EDT
pychess 0.12.4-3 pulls in pygobject2 so that problem shouldn't be there any more.
Comment 19 Raphael Groner 2016-06-27 05:43:18 EDT
The new builds work in Cinnamon/F23 but not in LXQt/F24.

ERROR: Not all dependencies installed! You can find them in INSTALL
Namespace GtkSource not available for version 3.0
Comment 20 Bruno Wolff III 2016-06-27 11:05:17 EDT
How did you get this to happen?
I suspect I am just missing some requires, but I need a way to test it.
Comment 21 Raphael Groner 2016-06-27 12:33:01 EDT
Need to install gtksourceview3, maybe you can drop gtksourceview2.
Comment 22 Bruno Wolff III 2016-06-27 16:46:09 EDT
I confirmed the issue and will fix it tonight. Hopefully this won't be a problem for f23. (I'll check on that tonight as well.)
gtksourceview2 is pulled in indirectly through pygtksourceview and that won't change for now.
Thanks for figuring this out.
Comment 23 Bruno Wolff III 2016-06-27 21:16:02 EDT
I have new builds out that force gtksourceview3 to be installed.
Comment 24 Raphael Groner 2016-06-28 07:03:17 EDT
Coming back to initial problem:
> waiting time about 5 secs before pc does a pc initiated move

Did you try to limit thinking time in settings?
Comment 25 joerg.lechner 2016-06-28 07:48:34 EDT
No, I didn't. But what I see now in F23 seems to be ok (see comment 14). Normal reaction time for normal look ups in the data base for how to react, if it becomes more difficult for Pychess, this means, a quick search for "how to react" is not successful, the reaction time rises untill the answer of the system might be like that "no book example found for how to react", in this case the system is unable react useful and it is very easy to defeat the "PC". If You want an example for this reaction of the system, I can easily make one and send the data concerníng.
Comment 26 joerg.lechner 2016-07-05 10:57:25 EDT
Hi, I think it's the best to give a notation of this Pychess situation (error?) in this bug - F24, last version of Pychess:
[joerg@linux ~]$ su
Passwort: 
[root@linux joerg]# dnf upgrade pychess
Fedora 24 - x86_64 - Updates                    5.6 MB/s | 8.5 MB     00:01    
Letzte Prüfung auf abgelaufene Metadaten: vor 0:00:04 am Tue Jul  5 16:33:48 2016.
Abhängigkeiten sind aufgelöst.
================================================================================
 Package                   Arch         Version             Paketquelle   Größe
================================================================================
Installieren:
 python-gobject            x86_64       3.20.1-1.fc24       fedora         22 k
 python-gobject-base       x86_64       3.20.1-1.fc24       fedora        297 k
Aktualisieren:
 pychess                   noarch       0.12.4-5.fc24       updates       3.4 M

Transaktionsübersicht
================================================================================
Installieren   2 Pakete
Aktualisieren  1 Paket

Gesamte Downloadgröße: 3.7 M
Ist dies in Ordnung? [j/N]: j
Pakete werden heruntergeladen:
(1/3): python-gobject-3.20.1-1.fc24.x86_64.rpm  379 kB/s |  22 kB     00:00    
(2/3): python-gobject-base-3.20.1-1.fc24.x86_64 1.7 MB/s | 297 kB     00:00    
(3/3): pychess-0.12.3-1.fc24_0.12.4-5.fc24.noar 3.0 MB/s | 1.0 MB     00:00    
[DRPM] pychess-0.12.3-1.fc24_0.12.4-5.fc24.noarch.drpm: Fertig                 
--------------------------------------------------------------------------------
Gesamt                                          101 kB/s | 1.3 MB     00:13     
Delta RPMs reduziert 3.7 MB Aktualisierungen auf 1.3 MB (65.1% gespart)
Transaktionsüberprüfung wird ausgeführt
Transaktionsprüfung war erfolgreich.
Transaktion wird getestet
Transaktionstest war erfolgreich.
Transaktion wird ausgeführt
  Installieren     : python-gobject-base-3.20.1-1.fc24.x86_64               1/4 
  Installieren     : python-gobject-3.20.1-1.fc24.x86_64                    2/4 
  Aktualisieren    : pychess-0.12.4-5.fc24.noarch                           3/4 
  Aufräumen        : pychess-0.12.3-1.fc24.noarch                           4/4 
  Überprüfung läuft: python-gobject-3.20.1-1.fc24.x86_64                    1/4 
  Überprüfung läuft: python-gobject-base-3.20.1-1.fc24.x86_64               2/4 
  Überprüfung läuft: pychess-0.12.4-5.fc24.noarch                           3/4 
  Überprüfung läuft: pychess-0.12.3-1.fc24.noarch                           4/4 

Installiert:
  python-gobject.x86_64 3.20.1-1.fc24  python-gobject-base.x86_64 3.20.1-1.fc24 

Aktualisiert:
  pychess.noarch 0.12.4-5.fc24                                                  

Komplett!
[root@linux joerg]# pychess
[root@linux joerg]# dnf install jdownloader
Letzte Prüfung auf abgelaufene Metadaten: vor 0:01:18 am Tue Jul  5 16:33:48 2016.
Kein Paket jdownloader verfügbar.
Fehler: Es konnte kein Treffer gefunden werden.
[root@linux joerg]# dnf install jd*
Letzte Prüfung auf abgelaufene Metadaten: vor 0:01:35 am Tue Jul  5 16:33:48 2016.
Abhängigkeiten sind aufgelöst.
================================================================================
 Package                   Arch   Version                         Paketquelle
                                                                          Größe
================================================================================
Installieren:
 ant                       noarch 1.9.6-3.fc24                    fedora  183 k
 ant-lib                   noarch 1.9.6-3.fc24                    fedora  1.8 M
 antlr3-java               noarch 1:3.5.2-11.fc24                 fedora  173 k
 apache-commons-codec      noarch 1.10-3.fc24                     fedora  247 k
 apache-commons-io         noarch 1:2.4-15.fc24                   fedora  192 k
 apache-commons-logging    noarch 1.2-5.fc24                      fedora   86 k
 base64coder               noarch 20101219-14.fc24                fedora   18 k
 cglib                     noarch 3.1-10.fc24                     fedora  266 k
 classmate                 noarch 1.2.0-3.fc24                    fedora   72 k
 cmigemo                   x86_64 1.3-0.11.date20110227.fc24.4    fedora  4.3 M
 geronimo-jpa              noarch 1.1.1-17.fc24                   fedora   52 k
 geronimo-jta              noarch 1.1.1-19.fc24                   fedora   25 k
 glassfish-servlet-api     noarch 3.1.0-10.fc24                   fedora   87 k
 hamcrest-core             noarch 1.3-14.fc24                     fedora   56 k
 hsqldb1                   noarch 1.8.1.3-10.fc24                 fedora  720 k
 httpcomponents-client     noarch 4.5.2-2.fc24                    fedora  700 k
 httpcomponents-core       noarch 4.4.4-2.fc24                    fedora  633 k
 java-1.8.0-openjdk        x86_64 1:1.8.0.92-3.b14.fc24           updates 226 k
 java-1.8.0-openjdk-devel  x86_64 1:1.8.0.92-3.b14.fc24           updates 9.8 M
 jaxen                     noarch 1.1.6-8.fc24                    fedora  215 k
 jboss-connector-1.7-api   noarch 1.0.0-4.fc24                    fedora   73 k
 jboss-logging             noarch 3.3.0-1.fc24                    updates  74 k
 jd                        x86_64 2.8.9-2.fc24                    fedora  1.5 M
 jday                      x86_64 2.4-14.fc24                     fedora   27 k
 jday-devel                x86_64 2.4-14.fc24                     fedora   11 k
 jdbi                      noarch 2.63.1-2.fc24                   fedora  320 k
 jdbi-javadoc              noarch 2.63.1-2.fc24                   fedora  253 k
 jdeparser                 noarch 2.0.0-1.fc24                    updates 215 k
 jdeparser-javadoc         noarch 2.0.0-1.fc24                    updates 446 k
 jdeparser1                noarch 1.0.0-1.fc24                    updates 166 k
 jdeparser1-javadoc        noarch 1.0.0-1.fc24                    updates 156 k
 jdepend                   noarch 2.9.1-15.fc24                   fedora  183 k
 jdepend-demo              noarch 2.9.1-15.fc24                   fedora   18 k
 jdepend-javadoc           noarch 2.9.1-15.fc24                   fedora   54 k
 jdependency               noarch 0.9-4.fc24                      fedora   36 k
 jdependency-javadoc       noarch 0.9-4.fc24                      fedora   35 k
 jdf-stacks-client         noarch 1.0.2-5.fc24                    fedora   44 k
 jdf-stacks-client-javadoc noarch 1.0.2-5.fc24                    fedora   55 k
 jdiff                     noarch 1.1.1-10.fc24                   fedora  177 k
 jdiff-javadoc             noarch 1.1.1-10.fc24                   fedora   60 k
 jdns                      x86_64 2.0.3-2.fc24                    fedora   50 k
 jdns-devel                x86_64 2.0.3-2.fc24                    fedora   18 k
 jdo-api                   noarch 3.1-0.8.rc1.fc24                fedora  210 k
 jdo-api-javadoc           noarch 3.1-0.8.rc1.fc24                fedora  302 k
 jdo2-api                  noarch 2.2-12.fc24                     fedora  148 k
 jdo2-api-javadoc          noarch 2.2-12.fc24                     fedora  240 k
 jdom                      noarch 1.1.3-10.fc24                   fedora  180 k
 jdom-demo                 noarch 1.1.3-10.fc24                   fedora   37 k
 jdom-javadoc              noarch 1.1.3-10.fc24                   fedora  169 k
 jdom2                     noarch 2.0.6-5.fc24                    fedora  883 k
 jdom2-javadoc             noarch 2.0.6-5.fc24                    fedora  367 k
 junit                     noarch 1:4.12-4.fc24                   fedora  298 k
 mona-vlgothic-fonts       noarch 2.90-21.fc24                    fedora  1.3 M
 objectweb-asm             noarch 5.0.4-2.fc24                    fedora  582 k
 publicsuffix-list         noarch 20160323-1.fc24                 fedora   69 k
 snakeyaml                 noarch 1.16-2.fc24                     fedora  243 k
 springframework           noarch 3.2.15-3.fc24                   fedora  637 k
 springframework-beans     noarch 3.2.15-3.fc24                   fedora  540 k
 springframework-jdbc      noarch 3.2.15-3.fc24                   fedora  355 k
 springframework-tx        noarch 3.2.15-3.fc24                   fedora  204 k
 tomcat-el-3.0-api         noarch 1:8.0.32-4.fc24                 fedora  107 k
 ttmkfdir                  x86_64 3.0.9-48.fc24                   fedora   56 k
 xalan-j2                  noarch 2.7.1-28.fc24                   fedora  1.9 M
 xerces-j2                 noarch 2.11.0-24.fc24                  fedora  1.2 M
 xml-commons-apis          noarch 1.4.01-20.fc24                  fedora  232 k
 xml-commons-resolver      noarch 1.2-19.fc24                     fedora  114 k
 xorg-x11-fonts-Type1      noarch 7.5-16.fc24                     fedora  522 k

Transaktionsübersicht
================================================================================
Installieren  67 Pakete

Gesamte Downloadgröße: 34 M
Installationsgröße: 114 M
Ist dies in Ordnung? [j/N]: n
Vorgang abgebrochen.
[root@linux joerg]# pychess
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
x

(pychess:2543): Gtk-CRITICAL **: gtk_box_gadget_distribute: assertion 'size >= 0' failed in pychess+widgets+InfoBar+InfoBarNotebook

(pychess:2543): Gtk-CRITICAL **: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkNotebook

(pychess:2543): Gtk-CRITICAL **: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkNotebook

(pychess:2543): Gtk-CRITICAL **: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkNotebook
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

(pychess:2543): dconf-WARNING **: failed to commit changes to dconf: Verbindung ist geschlossen

(pychess:2543): dconf-WARNING **: failed to commit changes to dconf: Verbindung ist geschlossen

(


Please see files, screenshot attached:
Comment 27 joerg.lechner 2016-07-05 10:59 EDT
Created attachment 1176523 [details]
Pychess 12 cuts communication an stops: F24 or Pychess error
Comment 28 joerg.lechner 2016-07-05 11:00 EDT
Created attachment 1176524 [details]
Pychess 12 cuts communication an stops: F24 or Pychess error
Comment 29 Sergio Monteiro Basto 2016-07-24 20:27:36 EDT
(In reply to joerg.lechner from comment #26)
(F24 or Pychess error ) now is new bug ? ,  you wrote (comment 25) "But what I see now in F23 seems to be ok (see comment 14)" . So close this bug as fixed and open a new one , with the new bug . 
Analyzing https://bugzilla.redhat.com/attachment.cgi?id=1176523 whites loose by time ([WhiteClock "23:59:59.927"]) , try use other chess engine you got stockfish engine in fedora repos .
Comment 30 joerg.lechner 2016-07-25 11:53:57 EDT
I will try to get a second chance to find the error in F24 as mentioned in comment 26, since then I used F23. If yes I will file another bug.
Comment 31 Sergio Monteiro Basto 2016-07-25 12:10:06 EDT
After so much work, we deserve mark as fixed .

Note You need to log in before you can comment on or make changes to this bug.