Bug 127275 - execvp: No such file or directory
execvp: No such file or directory
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bash (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 14:56 EDT by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-05 17:58:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-07-05 14:56:09 EDT
Description of problem:
I am at my wit's end and need some help. I am running thje
firewall-2.4 stroger script on Redhat 7.3 currently with no problem

(http://www.ecst.csuchico.edu/~dranc...ll-2.4-stronger)

I just got a copy of redhat enterprise Linuux 3.0 and I am trying to
replace the 7.3 box with rhel 3.0 .

Now here is the confusion, I cannot seem to run this same script on
rhel 3.0. When i try running it manually from command line, I get the
error:

[root@mybox root]# ./firewall.iptables
: bad interpreter: No such file or directory

When I place the script in the /etc/rc.d/init.d folder and create the
appropriate links to the runlevels I want and boot up I get this error
instead:

execvp: nosuch file or directory

As you can see from the script, it has the apropriate path to sh (i.e.
#!/bin/sh).The bad Interprator seems to indicate it cannot find the sh
or bash shell or something. Which is really weird because it works
without a hitch on Redhat 7.3.

I have read various posts about this problem but could not find a
conclusive fix for it . I found some hints that seem to indicate the
execvp error is created by the /etc/rc.d/init.d/functions script but
again no definite fix.

I am desperate and any help or suggestion will be greatly appreciated.

Kofi.


Version-Release number of selected component (if applicable):


How reproducible:
Easy

Steps to Reproduce:
1. Download the script from
(http://www.ecst.csuchico.edu/~dranc...ll-2.4-stronger)

2.Run the script manually: ./firewall.iptables-2.4

3.Or place script in init script directory and activate during bootup.
  
Actual results:
When the shell script is manually, it  responds: 

bad interpreter: No such file or directory

When run as an int script during bootup it  says: 

execvp: No such file or directory.

Expected results:
It should just run the shell script and load up the firewall iptables
rules.

Additional info:




Expected results:


Additional info:
Comment 1 Tim Waugh 2004-07-05 17:58:56 EDT
URL doesn't work.

I expect you have a carriage return before the linefeed at the end of
the first line.

Note You need to log in before you can comment on or make changes to this bug.