Bug 1272767 - NetworkManager L2TP with IPSec completely unusable!
NetworkManager L2TP with IPSec completely unusable!
Status: CLOSED DUPLICATE of bug 887674
Product: Fedora
Classification: Fedora
Component: NetworkManager-l2tp (Show other bugs)
23
x86_64 Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ivan Romanov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-18 14:51 EDT by Andrea Oliveri
Modified: 2016-01-25 08:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 08:55:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Oliveri 2015-10-18 14:51:57 EDT
L2TP plugin with IPSec PSK it is completely unusable because:
1) ipsec service doesn't start automatically, you have to enable it with systemctl
2) ipsec doesn't find *.secret files (the plugin doesn't generate it)
3) ipsec.conf generated by the plugins contains "VERSION 2" line incompatible with libreswan
4) if you insert manually a proper *.secret file in /etc/ipsec.d (enables it in /etc/ipsec.conf and removing "VERSION 2") the plugins fails with
<warn> VPN connection 'VPN' failed to connect: 'Possible error in IPSec setup.'.
<warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
and ipsec log doesn't show any error or warn message.
Selinux: disabled.
Please fix it..
Comment 1 Ivan Romanov 2015-10-20 00:29:21 EDT
Sorry I can't help here.

https://bugzilla.redhat.com/show_bug.cgi?id=887674#c105
Comment 2 Andrea Oliveri 2015-11-09 09:21:22 EST
please, someone can fix it?
Comment 3 Blueowl 2016-01-25 08:55:17 EST

*** This bug has been marked as a duplicate of bug 887674 ***

Note You need to log in before you can comment on or make changes to this bug.