Bug 127278 - Screen corruption/server segfault switching back & forth between X and text console on Silicon Motion LynxE
Screen corruption/server segfault switching back & forth between X and text c...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 16:15 EDT by Matt Dainty
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 13:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Dainty 2004-07-05 16:15:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20040603

Description of problem:
Hardware is an HP OmniBook XE with a Silicon Motion LynxE PCI chipset
with a 12.1" HPA/DSTN screen (800x600), running latest Core 2 as of
04/07/2004.

When switching from X to text console and back again, the X desktop
has slid down the screen by about 1", and sometimes to the left side
slightly such that the mouse will wrap off of the left side onto the
right, and can disappear off the bottom of the screen (but doesn't
wrap to the top again).

If I then switch to text console and back to X again, the server dies
with a segfault and restarts from init again, display restored
correctly. This can be repeated over and over again.

Problem occurs in all colour depths, 8 and 16-bit just shifts the
display, but 24-bit also shifts colours slightly, from the bluey
Fedora GDM screen to a more greeny colour.

Same hardware running Core 1/XFree86 didn't have this problem,
switching worked fine without problem.

Looks like video memory is being shifted/trampled over.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. Boot into runlevel 5 (GDM)
2. Ctrl+Alt+F1 to text console
3. Alt+F7 back to X, desktop is now shifted down the screen by ~ 1"
4. Ctrl+Alt+F1 to text console again
5. Alt+F7 back to X, server dies and gets restarted back to normal
6. Lather, Rinse, Repeat
    

Additional info:
Comment 2 Mike A. Harris 2004-08-31 13:28:45 EDT
The siliconmotion driver has been updated in X.Org CVS for the
new release, which we have in Fedora Core development currently.

You can upgrade to xorg-x11-6.7.99.903 or later from fedora devel,
and test the new siliconmotion driver if you like.  If the new
driver also exhibits this problem, you can file a bug report in
the X.Org bugzilla located at: http://bugs.freedesktop.org in the
"xorg" component, for the driver maintainer(s) to investigate.

If you paste your upstream X.Org bugzilla URL here, we will also
track the issue for you in the upstream bugzilla.

Thanks for testing fedora devel x11.

Setting status to "RAWHIDE"

Note You need to log in before you can comment on or make changes to this bug.