Bug 1272835 - SELinux is preventing /usr/sbin/named from 'name_bind' accesses on the udp_socket port 61000.
SELinux is preventing /usr/sbin/named from 'name_bind' accesses on the udp_so...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
high Severity medium
: ---
: ---
Assigned To: Vit Mojzis
Fedora Extras Quality Assurance
abrt_hash:550ad5df669ae00dd636893272f...
:
: 1221677 1276231 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 00:14 EDT by vikram goyal
Modified: 2015-11-26 22:53 EST (History)
8 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-128.21.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 22:53:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vikram goyal 2015-10-19 00:14:16 EDT
Description of problem:
SELinux is preventing /usr/sbin/named from 'name_bind' accesses on the udp_socket port 61000.

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If you want to allow system to run with NIS
Then you must tell SELinux about this by enabling the 'nis_enabled' boolean.
You can read 'named_selinux' man page for more details.
Do
setsebool -P nis_enabled 1

*****  Plugin catchall (11.6 confidence) suggests   **************************

If you believe that named should be allowed name_bind access on the port 61000 udp_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep named /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:named_t:s0
Target Context                system_u:object_r:ephemeral_port_t:s0
Target Objects                port 61000 [ udp_socket ]
Source                        named
Source Path                   /usr/sbin/named
Port                          61000
Host                          (removed)
Source RPM Packages           bind-9.10.2-5.P4.fc22.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.16.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-200.fc22.x86_64 #1 SMP Thu
                              Oct 8 03:23:55 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-10-19 01:28:44 IST
Last Seen                     2015-10-19 01:28:44 IST
Local ID                      085fb678-fb39-4b1c-b8aa-23e2d336cadc

Raw Audit Messages
type=AVC msg=audit(1445198324.198:1040): avc:  denied  { name_bind } for  pid=1725 comm="named" src=61000 scontext=system_u:system_r:named_t:s0 tcontext=system_u:object_r:ephemeral_port_t:s0 tclass=udp_socket permissive=1


type=SYSCALL msg=audit(1445198324.198:1040): arch=x86_64 syscall=bind success=yes exit=0 a0=212 a1=7f3e29ad3450 a2=10 a3=7f3e29ad3238 items=0 ppid=1 pid=1725 auid=4294967295 uid=25 gid=25 euid=25 suid=25 fsuid=25 egid=25 sgid=25 fsgid=25 tty=(none) ses=4294967295 comm=named exe=/usr/sbin/named subj=system_u:system_r:named_t:s0 key=(null)

Hash: named,named_t,ephemeral_port_t,udp_socket,name_bind

Version-Release number of selected component:
selinux-policy-3.13.1-128.16.fc22.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.3-200.fc22.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-10 03:38:44 EST
We have fixes in Fedora Rawhide.

Vit,
could you please backport them? Thank you.
Comment 3 Vit Mojzis 2015-11-19 04:02:44 EST
*** Bug 1276231 has been marked as a duplicate of this bug. ***
Comment 4 Vit Mojzis 2015-11-19 04:11:43 EST
*** Bug 1221677 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2015-11-20 08:12:00 EST
selinux-policy-3.13.1-128.21.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bbd3df966
Comment 6 Fedora Update System 2015-11-21 12:51:06 EST
selinux-policy-3.13.1-128.21.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update selinux-policy'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bbd3df966
Comment 7 Fedora Update System 2015-11-26 22:52:03 EST
selinux-policy-3.13.1-128.21.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.