Bug 1272884 - EncryptedCinderVolumes Tempest fails with iSER
EncryptedCinderVolumes Tempest fails with iSER
Status: CLOSED DUPLICATE of bug 1273466
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 5.0 (RHEL 7)
Assigned To: Eoghan Glynn
nlevinki
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 03:08 EDT by Lenny Verkhovsky
Modified: 2015-11-02 04:26 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 12:49:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lenny Verkhovsky 2015-10-19 03:08:22 EDT
Description of problem:
Encryption/decryption of the volume test fails

Version-Release number of selected component (if applicable):
packstack-2015.1-0.11.dev1589.g1d6372f.el7ost.noarch
Kilo version

Steps to Reproduce:
1. Install packstack on RHEL7
2. configure iSER
2. run tempest testr run tempest.scenario.test_encrypted_cinder_volumes.TestEncryptedCinderVolumes

Actual results:
test fails

Expected results:
test passes

Additional info:
rpm -qa|grep packstack
openstack-packstack-2015.1-0.11.dev1589.g1d6372f.el7ost.noarch

Solution:
The following patch fixes the issue https://review.openstack.org/#/c/197713/

Related bug comment
 https://bugzilla.redhat.com/show_bug.cgi?id=1268051#c6
Comment 1 Lee Yarwood 2015-10-30 12:49:19 EDT

*** This bug has been marked as a duplicate of bug 1268051 ***
Comment 2 Lee Yarwood 2015-11-02 04:26:11 EST

*** This bug has been marked as a duplicate of bug 1273466 ***

Note You need to log in before you can comment on or make changes to this bug.