Bug 1272893 - debhelper-9.20150628-1.fc24 FTBFS: Dependency on Test module not declared
debhelper-9.20150628-1.fc24 FTBFS: Dependency on Test module not declared
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: debhelper (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 03:38 EDT by Petr Pisar
Modified: 2015-10-22 09:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: debhelper-9.20150628-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 06:28:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-10-19 03:38:17 EDT
debhelper-9.20150628-1.fc24 fails to build in F24 because tests fail:

./run perl -MTest::Harness -e 'runtests grep { ! /CVS/ && ! /\.svn/ && -f && -x } @ARGV' t/* t/buildsystems/*
t/dh-lib .......................... ok
Can't locate Test.pm in @INC (you may need to install the Test module) (@INC contains: /builddir/build/BUILD/debhelper /builddir/build/BUILD/debhelper /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at t/dh_install line 2.
BEGIN failed--compilation aborted at t/dh_install line 2.
t/dh_install ...................... 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 

This is because Test module was moved from perl package into separate package and debhelper does not declare the build-time dependency.
Comment 1 Sergio Monteiro Basto 2015-10-22 00:42:58 EDT
Hi, 
Can you provide a patch ? or what I need to add ?
Comment 2 Petr Pisar 2015-10-22 04:58:06 EDT
I fixed it. There were many missing dependencies. I removed the "man-db" from build-requires because I could not find where it is used.

In case of Perl, if you need a "Test" Perl module for building a package, you will need to add "BuildRequire: perl(Test)".
Comment 3 Sergio Monteiro Basto 2015-10-22 09:00:03 EDT
Thanks

Note You need to log in before you can comment on or make changes to this bug.