Bug 1272905 - perl-DBIx-Class-0.082820-2.fc24 FTBFS: Failed test 'Deploying the bad schema produces a warning: aba_name_artists was not created.'
perl-DBIx-Class-0.082820-2.fc24 FTBFS: Failed test 'Deploying the bad schema ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-DBIx-Class (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 03:55 EDT by Petr Pisar
Modified: 2015-11-12 21:50 EST (History)
4 users (show)

See Also:
Fixed In Version: perl-DBIx-Class-0.082820-3.fc24 perl-DBIx-Class-0.082820-3.fc23 perl-DBIx-Class-0.082810-3.fc22 perl-DBIx-Class-0.08250-7.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 18:28:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 107852 None None None Never

  None (edit)
Description Petr Pisar 2015-10-19 03:55:08 EDT
perl-DBIx-Class-0.082820-2.fc24 fails to build in F24 because tests fail:

t/104view.t ......................................... ok
#   Failed test 'Deploying the bad schema produces a warning: aba_name_artists was not created.'
#   at t/105view_deps.t line 79.
# didn't find a warning
# expected to find warning: (?^:no such table: main.aba_name_artists)
#   Failed test 'Query on AbaNameArtistsAnd2010CDsWithManyTracks throws, because the table does not exist'
#   at t/105view_deps.t line 110.
# expecting: Regexp ((?^:no such table: aba_name_artists_and_2010_cds_with_many_tracks))
# found: normal exit
# Looks like you failed 2 tests of 25.
t/105view_deps.t .................................... 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/25 subtests 

Difference between working and failing build root:

        sqlite 	3.8.11.1-1.fc24 	> 	3.9.0-1.fc24
	xkeyboard-config 	2.15-2.fc23 	> 	2.16-1.fc24
	libreport-filesystem 	2.6.2-5.fc24 	> 	2.6.3-1.fc24
	perl-Image-Base 	1.17-3.fc23 	> 	1.17-4.fc24
	pinentry 	0.9.6-2.fc24 	> 	0.9.6-3.fc24
	kernel-headers 	4.3.0-0.rc5.git0.1.... 	> 	4.3.0-0.rc5.git1.1....
	xorg-x11-font-utils 	1:7.5-29.fc23 	> 	1:7.5-30.fc24
Comment 1 Petr Pisar 2015-10-19 05:19:15 EDT
This is caused by upgrading sqlite from 3.8.11.1-1.fc24 to 3.9.0-1.fc24.
Comment 2 Petr Pisar 2015-11-03 09:39:36 EST
All Fedoras seems affected.
Comment 3 Fedora Update System 2015-11-03 09:44:56 EST
perl-DBIx-Class-0.082820-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-e6bda53fce
Comment 4 Fedora Update System 2015-11-03 10:06:27 EST
perl-DBIx-Class-0.082810-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1fb6fd641d
Comment 5 Fedora Update System 2015-11-03 10:08:31 EST
perl-DBIx-Class-0.08250-7.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b27fef4edc
Comment 6 Fedora Update System 2015-11-03 13:20:44 EST
perl-DBIx-Class-0.08250-7.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update perl-DBIx-Class'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b27fef4edc
Comment 7 Fedora Update System 2015-11-03 13:56:08 EST
perl-DBIx-Class-0.082810-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update perl-DBIx-Class'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1fb6fd641d
Comment 8 Fedora Update System 2015-11-03 14:51:59 EST
perl-DBIx-Class-0.082820-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update perl-DBIx-Class'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-e6bda53fce
Comment 9 Fedora Update System 2015-11-12 18:28:03 EST
perl-DBIx-Class-0.082820-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2015-11-12 20:52:25 EST
perl-DBIx-Class-0.082810-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-11-12 21:50:24 EST
perl-DBIx-Class-0.08250-7.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.