Bug 1272917 - Fixing several grammar fixes
Fixing several grammar fixes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Petr Hracek
Alois Mahdal
: Extras
Depends On:
Blocks: 1335121
  Show dependency treegraph
 
Reported: 2015-10-19 04:31 EDT by Petr Hracek
Modified: 2016-11-04 04:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: preupgrade-assistant-2.1.9-6.el6
Doc Type: No Doc Update
Doc Text:
This bug only polish preupgrade-assistant texts
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:56:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Hracek 2015-10-19 04:31:14 EDT
Description of problem:
Some documentation is out-dated and should be fixed.
Like README, Preupgrade-asssistant API.

Look on all documentation and do update together of content services.
Comment 2 Petr Hracek 2015-11-03 07:58:05 EST
Here is a list of all documents available in preupgrade-assistant package:
- man/preupg.1
- man/preupg-content-creator.1
- man/preupgrade-assistant-api.1
- preup/settings.py - several texts used by preupgrade-assistant
- preup-conf/preupgrade-assistant.conf - texts describe configuration file
- preup_creator/settings.py - texts used for generation contents from scratch
- README
- README.kickstart
- README.md

log_message function used by preupgrade-assistant:
preup/utils.py:78:        log_message("Provided file is not a valid XML file", level=logging.ERROR)
preup/utils.py:110:            log_message("Problem with getting interpreter", level=logging.ERROR)
preup/utils.py:314:            log_message("Problem with copying tarball {0} to /root/preupgrade-results".format(tarball))
preup/application.py:509:                log_message("Your scan have wrong format",
preup/application.py:511:                log_message("Examples format is like RHEL6_7",
preup/application.py:534:        log_message("Tarball with results is stored here %s ." % tar_ball_name)
preup/application.py:535:        log_message("The latest assessment is stored in directory %s ." % self.conf.result_dir)
preup/application.py:557:                log_message('Summary information:')
preup/application.py:563:                    log_message("Read the %s report file %s for more details." % (report_type, report_name))
preup/application.py:568:            log_message('Summary 3rd party providers:')
preup/application.py:571:                log_message("Read the 3rd party content {0} {1} for more details.".
preup/application.py:573:        log_message("Upload results to UI by command:\ne.g. {0} .".format(command))
preup/application.py:619:                log_message("'preupg' command was not run yet. Run them before kickstart generation.")
preup/application.py:638:                log_message("There were no contents found in directory %s. \
preup/application.py:642:                log_message("There only 1 set of contents is allowed directory %s. \
preup/application.py:651:                log_message('Specify correct upgrade path parameter like -s RHEL6_7')
preup/application.py:652:                log_message('Upgrade path is provided by command preupg --list')
preup/application.py:655:                log_message('Specify correct upgrade path parameter like -s RHEL6_7')
preup/application.py:656:                log_message('Upgrade path is provided by command preupg --list')
preup/application.py:673:                log_message("Oscap with SCE enabled is not installed")
preup/application.py:676:                log_message("Oscap with SCE %s is not executable" % self.binary)
preup/common.py:56:        log_message("Gathering logs used by preupgrade assistant:")
preup/kickstart.py:322:            log_message("Can't read system kickstart at {0}".format(system_ks_path))
preup/kickstart.py:326:                log_message("There is no KS_TEMPLATE_POSTSCRIPT specified in settings.py")
preup/kickstart.py:328:                log_message("Can't read kickstart template {0}".format(settings.KS_TEMPLATE))
preup/kickstart.py:424:            log_message('KS_TEMPLATE_POSTSCRIPT is not defined in settings.py')
preup/kickstart.py:428:            log_message("Can't open script template: {0}".format(script_path))
preup/kickstart.py:456:                    log_message("Copying %s to %s failed" % (source_name, target_name))
preup/kickstart.py:464:            log_message("File %s is missing. Partitioning layout has not to be complete." % filename, level=logging.WARNING)
preup/kickstart.py:494:            log_message("File %s was not generated by a content. Kickstart does not contain partitioning layout" % lsblk_filename)
preup/kickstart.py:548:            log_message("Important data are missing for kickstart generation.", level=logging.ERROR)
preup/remediate.py:24:        log_message("No postupgrade scripts available")
preup/remediate.py:52:    log_message('Running postupgrade scripts:')
preup/remediate.py:57:        log_message('Executing script %s' % scr)
preup/remediate.py:60:        log_message("Executing script %s ...done" % scr)
preup/remediate.py:90:        log_message("File name to copy '%s'" % filename,
preup/remediate.py:112:                log_message("File '%s' already exists in dirtyconf directory" % target_name,
preup/remediate.py:118:            log_message("Copying file '%s' to '%s' failed." % (filename, target_name),
Comment 5 Alois Mahdal 2016-05-15 12:11:25 EDT
I don't know what you mean by "a bit"; it really depends on how much text you want to translate.
Comment 11 Petr Hracek 2016-09-14 05:52:46 EDT
Please look at the commits mentioned above.

All texts were reviewed by Jiri Hornicek already.

All manual pages, preupgrade-assistant codes, READMEs and settings.py
Comment 13 Alois Mahdal 2016-10-18 10:02:07 EDT
The fixes done within this tracker are only grammar/cosmetic.  From that point of view it's clearly an improvement but the texts still suffer from problems such as incomplete, confusing (or even incorrect) info and poor style.

It's not possible at this moment to fix all these problems.  Also, it's not even preferable since some parts of p-a will be undergoing heavy changes in next cycle. 

We have agreed with @phracek on this solution: rather than dropping this from the erratum and reverting Jiří's changes, we change the focus of this bug to what was actually done.

Hence the title change done by Petr.
Comment 14 Alois Mahdal 2016-10-18 22:54:59 EDT
As agreed, verified upstream only (diffs from comment 6, comment 7 and comment 8), just focusing on possible code/syntax breakage.

No problems found.
Comment 16 errata-xmlrpc 2016-11-04 04:56:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2616.html

Note You need to log in before you can comment on or make changes to this bug.