Bug 1272918 - libnl3-devel-3.2.21-8.el7.x86_64.rpm is missing for RH7.2snap4
libnl3-devel-3.2.21-8.el7.x86_64.rpm is missing for RH7.2snap4
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libnl3 (Show other bugs)
7.2
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Thomas Haller
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 04:32 EDT by Or Kehati
Modified: 2015-10-19 12:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 12:47:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Or Kehati 2015-10-19 04:32:30 EDT
Description of problem:
RH7.2 snapshot 4 is missing the libnl3-devel package.
In order to compile against libnl3, libnl3-devel is required.

Version-Release number of selected component (if applicable):
The libnl3 version for RH7.2snap4 is libnl3-3.2.21-10.el7.x86_64.

How reproducible:
Trying to compile a library to work with libnl3 is failing.
For example, i'm trying to compile libvma (https://github.com/Mellanox/libvma) which require libnl or libnl3.
Since libnl3-devel does not exist, i have to compile against libnl-devel.
But libvma is also depending on libibverbs which is dependent on libnl3.
As a result, when loading libvma, both libnl3 and libnl are loaded, which causes a crash in libnl3.

Steps to Reproduce:
1.install libvma dependencies: libibverbs, librdmacm
2.compile libvma or any other library or tool depending on libnl3
3.load libvma: LD_PRELOAD=libvma.so ls

Actual results:
ls: route/tc.c:973: rtnl_tc_register: Assertion `0' failed.
Aborted (core dumped)

Expected results:
ls to print files in directory

Additional info:
Comment 2 Tomas Pelka 2015-10-19 06:22:20 EDT
Which variant are you using? Workstation, Client or Server? Devel packages are usually shipped in optional channel make sure your optional os enabled.
Comment 3 Or Kehati 2015-10-19 07:05:06 EDT
Sorry, i missed the optional channel.
I found the devel package.
thank you!
This bug can be closed.
Sorry again for the misunderstanding.
Comment 4 Tomas Pelka 2015-10-19 12:48:27 EDT
(In reply to Or Kehati from comment #3)
> Sorry, i missed the optional channel.
> I found the devel package.
> thank you!
> This bug can be closed.
> Sorry again for the misunderstanding.

No problem at all.

Note You need to log in before you can comment on or make changes to this bug.