Bug 127292 - glibc src rpm doesn't build glibc-common
Summary: glibc src rpm doesn't build glibc-common
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-06 04:57 UTC by Ken MacFarlane
Modified: 2016-11-24 15:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-06 07:28:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ken MacFarlane 2004-07-06 04:57:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
rpmbuild --rebuild glibc-2.3.3-33.src.rpm builds the glibc,
glibc-debuginfo, and ntpl binary packages, but not glibc-common. 
rpmbuild also reports many unpackaged files.  Also occurs on
glibc-2.3.3-31, glibc-2.3.3-31.1, glibc-2.3.3-32.



Version-Release number of selected component (if applicable):
glibc-2.3.3-33

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild --target=i686 glibc-2.3.3-33.src.rpm


Actual Results:  glibc, glibc-debuginfo, and ntpl binary packages
built, but not glibc-common

Expected Results:  all applicable packages built, no unpackaged files
found

Additional info:

warning: Installed (but unpackaged) file(s) found:
   /etc/nscd.conf
   /etc/rc.d/init.d/nscd
   /usr/lib/debug/usr/bin/gencat.debug
   /usr/lib/debug/usr/bin/getconf.debug
   /usr/lib/debug/usr/bin/getent.debug
   /usr/lib/debug/usr/bin/iconv.debug
   /usr/lib/debug/usr/bin/lddlibc4.debug
   /usr/lib/debug/usr/bin/locale.debug
   /usr/lib/debug/usr/bin/localedef.debug
   /usr/lib/debug/usr/bin/memusagestat.debug
   /usr/lib/debug/usr/bin/pcprofiledump.debug
   /usr/lib/debug/usr/bin/rpcgen.debug
   /usr/lib/debug/usr/bin/sprof.debug
   /usr/lib/debug/usr/lib/libBrokenLocale.a
   /usr/lib/debug/usr/lib/libanl.a
   /usr/lib/debug/usr/lib/libbsd-compat.a
   /usr/lib/debug/usr/lib/libc.a
   /usr/lib/debug/usr/lib/libc_nonshared.a
   /usr/lib/debug/usr/lib/libc_stubs.a
   /usr/lib/debug/usr/lib/libcrypt.a
   /usr/lib/debug/usr/lib/libdl.a
   /usr/lib/debug/usr/lib/libg.a
   /usr/lib/debug/usr/lib/libieee.a
   /usr/lib/debug/usr/lib/libm.a
   /usr/lib/debug/usr/lib/libmcheck.a
   /usr/lib/debug/usr/lib/libmemusage.so.debug
   /usr/lib/debug/usr/lib/libnsl.a
   /usr/lib/debug/usr/lib/libpcprofile.so.debug
   /usr/lib/debug/usr/lib/libpthread.a
   /usr/lib/debug/usr/lib/libpthread_nonshared.a
   /usr/lib/debug/usr/lib/libresolv.a
   /usr/lib/debug/usr/lib/librpcsvc.a
   /usr/lib/debug/usr/lib/librt.a
   /usr/lib/debug/usr/lib/libutil.a
   /usr/lib/debug/usr/libexec/pt_chown.debug
   /usr/lib/debug/usr/sbin/nscd.debug
   /usr/lib/debug/usr/sbin/rpcinfo.debug
   /usr/lib/debug/usr/sbin/zdump.debug
   /usr/lib/debug/usr/sbin/zic.debug
   /usr/lib/locale/locale-archive
   /usr/sbin/nscd_nischeck
   /usr/share/info/dir
(etc.)

Comment 1 Jakub Jelinek 2004-07-06 07:28:54 UTC
That's on purpose.  glibc-common is named common, because it contains
files common in between i386 and i686 builds and is only built in the
i386 build (similarly other subpackages).
If you for some strange reason which will only give you problems
(e.g. suddenly all programs you compile/link will be i686+ only),
you can remove i686 from auxarches at the top of glibc.spec.


Note You need to log in before you can comment on or make changes to this bug.