Bug 127296 - SCSI burner fails to write cd's in Fedora Core 2
SCSI burner fails to write cd's in Fedora Core 2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-06 01:39 EDT by Matthew
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: kernel-2.6.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 05:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The k3b log file. (1017 bytes, text/plain)
2004-07-06 01:42 EDT, Matthew
no flags Details
the /proc/scsi/scsi file (176 bytes, text/plain)
2004-07-06 21:39 EDT, Matthew
no flags Details
The results for the above commands (1.94 KB, text/plain)
2004-09-16 02:19 EDT, Matthew
no flags Details
The new k3b error log (3.68 KB, text/plain)
2004-09-29 19:27 EDT, Matthew
no flags Details
Output of cdrecord when trying to manually burn as root (2.68 KB, text/plain)
2004-10-07 20:54 EDT, Matthew
no flags Details

  None (edit)
Description Matthew 2004-07-06 01:39:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When I use ANY cd burning client packaged with Fedora (XCDRoast and
k3b) to burn cd's, there is always an error. It varies with the kernel
version, but the outcome is always the same. I will give the debug for
the default packaged kernel.

Sometimes, with a later version of the kernel, it appears to be doing
something, but then it freezes the computer, so that NOTHING operates.
Also, the CD is usually rendered useless.

I use a Matshita SCSI cd burner, that worked in FC1.

Version-Release number of selected component (if applicable):
cdrecord-2.01-0.a27.4.FC2.1 and later versions

How reproducible:
Always

Steps to Reproduce:
1. Run k3b or XCDRoast and try to burn any kind of cd
    

Actual Results:  It failed, as put under the DESCRIPTION box.

Expected Results:  The cd should have been burnt without any problems.

Additional info:
Comment 1 Matthew 2004-07-06 01:42:09 EDT
Created attachment 101653 [details]
The k3b log file.

The k3b log file, which clearly shows the errors. PLEASE NOTE: I have tried the
newest version from the Fedora repositories, but the error is the same.
Comment 2 Harald Hoyer 2004-07-06 04:01:12 EDT
can you please show me your /proc/scsi/scsi ??
Comment 3 Matthew 2004-07-06 21:39:08 EDT
Created attachment 101672 [details]
the /proc/scsi/scsi file

Of course ;) I have added the file as an attachment. Thankyou for your prompt
reply.
Comment 4 Graham King 2004-07-17 17:20:44 EDT
I get a similar error with a Sanyo CRD-BP4 scsi cd writer that worked
fine with gtoaster under RH8.
Comment 5 Matthew 2004-07-17 23:01:43 EDT
I assume that it would happen for all SCSI burners??? Either way I
hope this is resolved shortly. I NEED to burn cd's.
Comment 6 matt stat 2004-09-14 06:18:25 EDT
I can duplicate this bug, same symptoms, actions as the original
report.  I also had this problem in FC1.

The drive works in all respects except for recording.  Also works for
recording when booting into Windows.

My /proc/scsi/scsi is empty.  

Here's the output of my cdrecord --scanbus

Cdrecord-Clone 2.01a27-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
<warly@mandrakesoft.com>.
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Warning: Using badly designed ATAPI via /dev/hd* interface.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.80-RH '@(#)scsi-linux-sg.c       
1.80 04/03/08 Copyright 1997 J. Schilling').
scsibus1:
        1,0,0   100) 'SAMSUNG ' 'CDRW/DVD SM-308B' 'M002' Removable CD-ROM
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *

Comment 7 Harald Hoyer 2004-09-14 07:53:48 EDT
matt stat: you seem to have an IDE burner ... dev=ATA:1,0,0 
Comment 8 Harald Hoyer 2004-09-14 07:56:36 EDT
Matthew: does it work, if you try to burn as root?
Comment 9 matt stat 2004-09-14 08:17:54 EDT
Harald:  Yes, same problems with root (sorry for not mentioning this
earlier).
Comment 10 Matthew 2004-09-15 01:53:06 EDT
No... Same problem... Please note too that I was able to use it
properly in Fedora Core 1, without any of these new problems.

I have tried various updates to my kernel, bu they still fail. I have
assumed that there was a SCSI handling variation in either the kernel
or the Fedora Team. I still do not have a functional burner, which has
proved to be annoying on several occasions.

Thankyou for your support!
Comment 12 Matthew 2004-09-16 02:16:37 EDT
No... The burner still does not function, with the errors I originally
submitted still present. Thankyou for your support though.

A little extra information though:
"cdrecord -scanbus", as root or without, is included as an attachment.
"cdrecord -scanbus dev=/dev/scd0" is also included as an attachment.
Comment 13 Matthew 2004-09-16 02:19:49 EDT
Created attachment 103895 [details]
The results for the above commands
Comment 14 Matthew 2004-09-16 02:21:04 EDT
By the errors above, I mean the k3b error log.
Comment 15 matt stat 2004-09-18 07:23:54 EDT
I've done more searching around and find this file posted on a Debian
discussion group:

http://lists.debian.org/debian-user/2002/12/msg04993.html

The answers seem relevant, but are beyond my understanding.  They
involve telling the kernel to treat both the CDROM (reader) and the
CDRW  (writer) as SCSI devices at boottime.  However, I do not know
anything about the ide-scsi module the author is talking about (plus I
run grub and not lilo, as the article mentions, though I think that is
a small difference).
Comment 16 Matthew 2004-09-18 17:40:10 EDT
The difference is that my cd writer IS a SCSI drive, not and IDE
drive. From what I saw, the forum dealt with SCSI emulation for an IDE
drive.

These answers do not exactly remedy my problem, however they are
relevant. It just highlights this fact:
Something related to SCSI emulation/handling has changed between fc1
and fc2.

MattStat: Thanks for your efforts.

Harald: Has anything happened that is indicative of a fix in the near
future?
Comment 17 Harald Hoyer 2004-09-20 04:17:22 EDT
well, Matthew, if cdrecord-2.01.0.a38-2.i386.rpm does not fix your
problem, then it's probably s.th. other than cdrecord.
I suppose you haven't loaded any ide_scsi modules, cause it is a SCSI
burner.
Have you loaded the sr_mod and sg modules? Without them there are no
dev/sr0 and /dev/sg0. Btw, could you try to burn with "dev=/dev/sr0" ??
Comment 18 matt stat 2004-09-20 06:01:44 EDT
Harald,

Thanks for the reply.  As you suggested, I did load
cdrecord-2.01.a38-2.i386.rpm, which has not changed anything.

I have not loaded any ide_scsi modules.

Your suggestion about the modules may be in the right direction.  The
result of my cat /proc/modules is below.  Also, I can't see any
/dev/sr0 or any sr* devices.  I can see sg0 and other sg* devices. 
The modules you mentioned do, however, seem to be loaded.

And, of course, trying cdrecord dev=/dev/sr0 fails because of the lack
of the device.

cat /proc/modules
sr_mod 14309 0 - Live 0x22d6b000
vfat 12481 1 - Live 0x22d66000
fat 39393 1 vfat, Live 0x22d73000
snd_pcm_oss 43129 0 - Live 0x22d44000
snd_mixer_oss 14017 2 snd_pcm_oss, Live 0x22cee000
snd_ens1371 24869 1 - Live 0x22d3c000
snd_rawmidi 21733 1 snd_ens1371, Live 0x22d35000
snd_seq_device 6473 1 snd_rawmidi, Live 0x22c9c000
snd_pcm 83529 2 snd_pcm_oss,snd_ens1371, Live 0x22d50000
snd_page_alloc 8393 1 snd_pcm, Live 0x228bc000
snd_timer 25413 1 snd_pcm, Live 0x22ce0000
snd_ac97_codec 58821 1 snd_ens1371, Live 0x22d25000
snd 45477 8
snd_pcm_oss,snd_mixer_oss,snd_ens1371,snd_rawmidi,snd_seq_device,snd_pcm,snd_timer,snd_ac97_codec,
Live 0x22d18000
gameport 4033 1 snd_ens1371, Live 0x228b8000
soundcore 7713 2 snd, Live 0x228c2000
parport_pc 21249 1 - Live 0x22cd9000
lp 9133 0 - Live 0x22c94000
parport 35977 2 parport_pc,lp, Live 0x22ccf000
autofs4 20677 0 - Live 0x22cc8000
sunrpc 141861 1 - Live 0x22cf4000
3c59x 33385 0 - Live 0x22cbe000
ipt_REJECT 5057 1 - Live 0x22c91000
ipt_state 1857 7 - Live 0x228c0000
ip_conntrack 25569 1 ipt_state, Live 0x22c89000
iptable_filter 2369 1 - Live 0x22838000
ip_tables 13889 3 ipt_REJECT,ipt_state,iptable_filter, Live 0x2284c000
floppy 54001 0 - Live 0x2289b000
sg 28513 0 - Live 0x22861000
scsi_mod 105360 2 sr_mod,sg, Live 0x22ca3000
microcode 5601 0 - Live 0x2285e000
dm_mod 47317 0 - Live 0x228ab000
usblp 10817 0 - Live 0x22851000
uhci_hcd 28505 0 - Live 0x22856000
r128 92677 2 - Live 0x22883000
md5 3905 1 - Live 0x22828000
ipv6 217349 18 - Live 0x228c5000
ext3 96937 2 - Live 0x2286a000
jbd 66521 1 ext3, Live 0x2283a000
Comment 19 Harald Hoyer 2004-09-20 08:15:27 EDT
I think, I found the part where k3b/cdrecord fails... I am on it today
Comment 20 Matthew 2004-09-21 02:49:47 EDT
YAY!!!

Thankyou for your time and effort. Hopefully this also resolves my
issue ;)

Looking forward to your remedy!
Comment 21 Matthew 2004-09-29 19:24:20 EDT
Just so that you are aware, with the latest package of cdrecord
(2.01), there seems to be a different set of errors. Please see
attached error log (from k3b).
Comment 22 Matthew 2004-09-29 19:27:04 EDT
Created attachment 104554 [details]
The new k3b error log
Comment 23 Matthew 2004-09-29 19:31:47 EDT
I set the burning speed to 2x, and hey presto!!! It worked! So why is
this DMA speed severed? And why doesn't cdrecord automatically pick up
the information for the SCSI burner.

This is definately an improvement, so thankyou. All it needs now is a
little refinement.

Thanks again.
Comment 24 matt stat 2004-10-01 17:25:46 EDT
I have also loaded the new k3b, cdrecord and so on but still have the
same problems.  I'll try to be more specific.

I can read from the CD fine, copy from it, eject when finished and
everything else.  But when I try to copy from it I get the errors
listed in the above messages, plus I cannot eject the CD.  Not without
logging out, and sometimes not without rebooting the computer.

I just tried to write to a non-blank, but fairly empty, CD and had the
same problems.  The system again locked up, in the sense that I tried
to log out and it took forever to do so.

Since I'm not an expert user, it's hard for me to know what files
might be most relevant, but I found these errors in the system log
(amoung other things):

(this repeated many times)
Oct  1 17:15:53 68-174-163-45 gconfd (matt-6998): Failed to get lock
for daemon, exiting: Failed to lock '/tmp/gconfd-matt/lock/ior':
probably another process has the lock, or your operating system has
NFS file locking misconfigured (Resource temporarily unavailable)

(I thought I saw other messages about CD during reboot, but they don't
appear in the log.)

(then these upon bootup)
Oct  1 17:17:37 68-174-163-45 kernel: There is already a security
framework initialized, register_security failed.
Oct  1 17:17:37 68-174-163-45 kernel: vesafb: probe of vesafb0 failed
with error -6
Oct  1 17:17:37 68-174-163-45 kernel: cdrom: open failed.

Thanks.
Comment 25 Matthew 2004-10-03 17:30:03 EDT
Just to clarify your result for Harold :) :

By the "errors listed in the above messages", do you mean my most
recent bug report, or the earliest one?

Also, to eject your cd rom after burning (which I have had trouble
with before), try "mount -l" or "eject -l".

Harold: Have you found a solution to the DMA problem? Although burning
at 2x is better than not at all, I would prefer to burn faster than
that ;)

Thanks
Comment 26 matt stat 2004-10-04 06:30:48 EDT
Oh, sorry about the confusion.  I meant mine and the other original
errors that relate to not writing.

I still cannot write at any speed.  If I try the command cdrecord in a
terminal, that terminal locks up, and occasionally the entire computer
locks up.  I then usually move to log out, which can take up to 15
minutes as the computer sits and thinks; the only thing working is the
mouse, but nothing can be selected.  Sometimes even logging out fails
and I am forced to reboot.

I have tried the other eject commands with no success.

Thanks again.
Comment 27 Harald Hoyer 2004-10-04 10:47:54 EDT
btw, which kernel versions do you guys have?
Comment 28 matt stat 2004-10-05 06:52:16 EDT
Harald,

I'm with Fedora Core (2.6.8-1.521), kernel /vmlinuz-2.6.8-1.521.

Thanks.
Comment 29 Harald Hoyer 2004-10-05 08:33:22 EDT
matt, please have a look at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=130576
Comment 30 Matthew 2004-10-05 17:39:19 EDT
Sorry for the delay... I was installing a new 200GB hd... Now I'm done.

I am still using the 2.6.5-1.358 (default) since I did not like what
the 2.6.8 kernel did to some of my applications (just minor stuff).

What would be setting the DMA? And how do I fix it?
Comment 31 Matthew 2004-10-05 17:47:26 EDT
Also, it may help to know that a simple "cdrecord -scanbus" still does
not pick up the SCSI burner by default. You have to run "cdrecord
-scanbus dev=/dev/scd0".

It could be because of this:
scsidev: 'ATA'            as compared to            scsidev: '/dev/scd0'
devname: 'ATA'            as compared to            devname: '/dev/scd0'
Which appear halfway down the output of cdrecord.

Thanks again.
Comment 32 matt stat 2004-10-06 06:04:58 EDT
Harald,

I looked at the link you provided, but, and I may be wrong, but it
doesn't seem relevant.  I cannot write any kind of data, including audio.

In fact, I had this same problem with FC1 and with the earlier 2.4
kernels (again, the drive does write from windows).

I tried the 'cdrecord -scanbus dev=/dev/scd0' as Matthew suggested and
get the error message, "Cannot open '/dev/scd0'. Cannot open SCSI
driver." 

If I rerun with dev=/dev/cdrom I get the, I think correct, "scsibus0:
0,0,0     0) 'SAMSUNG ' 'CDRW/DVD SM-308B' 'M002' Removable CD-ROM."

I have also tried cursing at the drive repeatedly with no luck.

matt

Comment 33 Harald Hoyer 2004-10-06 06:57:54 EDT
matt, you do not have a scsi CDROM!
Comment 34 matt stat 2004-10-06 12:05:30 EDT
Harald,

I suppose this dramatically highlights my status as "naive linux
user."  And I feel bad about reporting a bug that's not accurate. 

Though I would appreciate any hints about how I can record even
without a scsi drive.

Thanks much.

Matt
Comment 35 Harald Hoyer 2004-10-06 12:32:44 EDT
matt, you may downgrade your kernel to the original FC2 kernel
Comment 36 Matthew 2004-10-06 20:38:34 EDT
matt, Don't feel too upset ;) I was a n00b not so long ago =).

Harald, Any closer to seeing my problem through? Writing at 2x is not
nice ;)
Comment 37 Harald Hoyer 2004-10-07 04:33:30 EDT
Matthew, cdrecord does some measurement at the beginning, and it seems
it can't push the data faster. There can be various reasons for that:
1. cdrecord's measurement is wrong
2. there is much disk io in the background
3. the driver for your SCSI card is crap
4. your SCSI card / drive is crap
What you can try is:
1. try to turn on burnfree, if your drive supports that
2. try to burn manually as root (root can enable realtime scheduling)
3. try to burn without background noise.

What I can do is to disable the speed checks. But first I want all
those kernel 2.6.8 issues resolved.
Comment 38 Harald Hoyer 2004-10-07 05:27:33 EDT
Matthew, you may also look at this:
http://www.redhat.com/archives/fedora-devel-list/2004-October/msg00302.html
Maybe the older kernel has some issues as well...
Comment 39 Matthew 2004-10-07 17:48:36 EDT
Harald, Thanks for the links. However, I am still using the original
kernel for fedora core 2. Does this version have these DMA problems?

Also, I KNOW the driver cannot be too crap, since in fedora core 1, it
worked seamlessly, with full writing speed enabled.

I do not have enough experience in this matter to know exactly what
the problem is, nor to fix it myself in the code (although I want to
be able to soon), but I hope we can figure out a solution before fc3.

I shall now try manual burn in root.

Thanks again,
Matthew
Comment 40 Matthew 2004-10-07 20:54:32 EDT
Created attachment 104918 [details]
Output of cdrecord when trying to manually burn as root

I have tried to (as root) manually burn an iso image. I have recored the
output, and saved it as this attachment. It came up exactly the same for
'driveropts=burnfree'. Hopefully this helps.

Regards,
Matthew
Comment 41 Matthew 2004-10-07 20:57:15 EDT
Oh yeah... The command I ran was (as root or user, both have the same
output): cdrecord dev=/dev/scd0 <iso location>.

Without the dev parameter, it cannot even see my burner. In fc1 it could.

Thanks again,
Matthew
Comment 42 Matthew 2004-10-08 20:40:12 EDT
Hope all goes well with fixing the bug... But at the moment I will not
be able to test anything, since my computers CPU has died... And it
might be a while before I can buy another one.

Thanks for all your help,
Matthew
Comment 43 Harald Hoyer 2004-12-08 06:47:45 EST
dooh... I am sorry for you!
Comment 44 Matthew Miller 2005-04-26 11:47:01 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 45 Harald Hoyer 2005-09-16 10:27:40 EDT
any news?
Comment 46 Matthew 2005-09-17 04:48:44 EDT
Fedora Core 4 works as it should =).
I am not sure about Fedora Core 3, since I hardly ever used it (since my
computer was down with the CPU problem).

Sorry about not updating it here, by the time I managed to get a functional
computer, I had long forgotten.

Thank you very much for your aid, Harold! I'm not sure what you have done, but
it worked ;).

Note You need to log in before you can comment on or make changes to this bug.