Bug 1272986 - [sharding+geo-rep]: On existing slave mount, reading files fails to show sharded file content
[sharding+geo-rep]: On existing slave mount, reading files fails to show shar...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1274600
  Show dependency treegraph
 
Reported: 2015-10-19 07:21 EDT by Rahul Hinduja
Modified: 2016-06-16 09:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1274600 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:40:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Hinduja 2015-10-19 07:21:00 EDT
Description of problem:
=======================

In geo-rep setup, when a data on file increases beyond 4M size the files gets synced to slave but reading file from slave mount only shows the original file content and not the content of sharded chunk. 

Unmounting and remounting the slave volume shows the proper content including sharded file contents. 

Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.8dev-0.929.gitbece485.el7rhgs.x86_64


How reproducible:
=================

Always


Steps to Reproduce:
===================
1. Create Master and Slave Cluster
2. Create Master and Slave Volume with meta_volume to true and features.shard on. Also enable performance.strict-write-ordering on the master volume
3. Create and Start geo-rep session
4. Mount master and slave volume
5. Create a file with total size less than 4M {I created file_1.9M with 1.9M of size}
6. File should sync to slave. Calculate arequal between master and slave, it should match. Do a diff of file between master and slave, should not show any output.
7. Append the existing file with data to grow total size more than 4M {I appended data of 3.4M to file_1.9M, total size thus becomes 5.2M}
8. Confirm 1 sharded file is created
9. Size at master and slave for file_1.9M is correctly shown as 5.2M but the arequal missmatches. diff shows data is not synced from master to slave. Their is a miss match in sharded files.
10. Umount the slave volume
11. Mount the slave volume again. The arequal matches

Actual results:
===============

On existing slave mount, the file content may be read from some cache


Expected results:
=================

On existing volume, the file should be read as whole including the shareded file content.
Comment 1 Vijay Bellur 2015-10-20 05:31:36 EDT
REVIEW: http://review.gluster.org/12400 (features/shard: Refresh cached size when lookup/readdirp detect that xattr value has changed) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2015-10-20 07:46:40 EDT
REVIEW: http://review.gluster.org/12400 (features/shard: Force cache-refresh when lookup/readdirp/stat detect that xattr value has changed) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2015-10-27 07:51:46 EDT
REVIEW: http://review.gluster.org/12400 (features/shard: Force cache-refresh when lookup/readdirp/stat detect that xattr value has changed) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Vijay Bellur 2015-10-28 03:04:25 EDT
REVIEW: http://review.gluster.org/12400 (features/shard: Force cache-refresh when lookup/readdirp/stat detect that xattr value has changed) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Vijay Bellur 2015-10-28 09:38:50 EDT
COMMIT: http://review.gluster.org/12400 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 8e5a7632edd040031e4942134331172805bc8eff
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Oct 20 11:46:10 2015 +0530

    features/shard: Force cache-refresh when lookup/readdirp/stat detect that xattr value has changed
    
    Change-Id: Ia3225a523287f6689b966ba4f893fc1b1fa54817
    BUG: 1272986
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12400
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Niels de Vos 2016-06-16 09:40:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.