Bug 1273009 - AttributeError: 'ZFCPDiskDevice' object has no attribute 'busid'
AttributeError: 'ZFCPDiskDevice' object has no attribute 'busid'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
23
s390x Linux
high Severity high
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
AcceptedFreezeException
: Reopened
Depends On:
Blocks: ZedoraTracker F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-19 08:09 EDT by Jan Stodola
Modified: 2015-10-26 17:01 EDT (History)
11 users (show)

See Also:
Fixed In Version: python-blivet-1.12.8-1 python-blivet-1.12.8-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 17:01:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2015-10-19 08:09:20 EDT
Description of problem:
I got the following traceback when running text mode kickstart installation on an s390x system with zFCP disk:

anaconda 23.19.7-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 655, in make_unformatted_dasd_list
    if blockdev.s390.dasd_needs_format(dasd.busid):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/spokes/storage.py", line 99, in __init__
    to_format = storage.devicetree.make_unformatted_dasd_list(getDisks(self.storage.devicetree))
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/hubs/__init__.py", line 64, in setup
    spoke = spokeClass(self.app, self.data, self.storage, self.payload, self.instclass)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 50, in setup
    should_schedule = TUIHub.setup(self, environment=environment)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/__init__.py", line 180, in setup
    should_schedule = obj.setup(self.ENVIRONMENT)
  File "/usr/sbin/anaconda", line 1320, in <module>
    anaconda._intf.setup(ksdata)
AttributeError: 'ZFCPDiskDevice' object has no attribute 'busid'


Similar traceback also reproduced when running:
* manual installation in text mode
* kickstart installation in both text and vnc mode

Version-Release number of selected component (if applicable):
http://s390pkgs.fedoraproject.org/compose/23_TC1/23/Server/s390x/os/
anaconda-23.19.7-1.fc23
python-blivet-1.12.7-1.fc23

How reproducible:
always

Steps to Reproduce:
1. have an s390x system with zFCP disk
2. run one of these installations:
 a) manual installation in text mode
 b) kickstart installation in text mode
 c) kickstart installation in vnc mode

Actual results:
anaconda traceback

Expected results:
successful installation

Additional info:
Not reproducible when running manual installation in vnc mode or when no zFCP disk is present
Comment 2 Fedora Blocker Bugs Application 2015-10-19 08:54:34 EDT
Proposed as a Freeze Exception for 23-final by Fedora user jstodola using the blocker tracking app because:

 Violating the following criterion:
https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#Network_attached_storage

Only proposing  as an exception, since this is happening on s390x (secondary architecture)
Comment 3 Adam Williamson 2015-10-19 16:03:06 EDT
Discussed at 2015-10-19 freeze exception review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-10-19/f23-blocker-review.2015-10-19-16.00.html . Accepted as a freeze exception issue as a serious issue in secondary storage.

Note as we're in release week and we have no outstanding anaconda blockers it is unlikely this will make it in if we release this week. If we slip and other anaconda issues are discovered, it's possible this may make it in. We'd like to ask the anaconda team to *only* apply a fix for this if it's very safe (i.e. clearly isolated to the zfcp codepath).
Comment 4 Samantha N. Bueno 2015-10-19 16:14:22 EDT
(In reply to awilliam@redhat.com from comment #3)
>
> other anaconda issues are discovered, it's possible this may make it in.
> We'd like to ask the anaconda team to *only* apply a fix for this if it's
> very safe (i.e. clearly isolated to the zfcp codepath).

Yes, it is. Actually I'm pretty sure the fix for this will be in blivet, but my statement remains true -- this is only going to affect a function that gets run on s390x.
Comment 5 Fedora Update System 2015-10-21 14:32:04 EDT
python-blivet-1.12.8-1.fc23 anaconda-23.19.9-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-da7ada8825
Comment 6 Jan Stodola 2015-10-23 02:37:42 EDT
All cases from comment 0 retested, no longer able to reproduce with python-blivet-1.12.8-1.fc23.
Thanks, moving to VERIFIED.
Comment 7 Fedora Update System 2015-10-24 08:08:48 EDT
anaconda-23.19.10-1.fc23, python-blivet-1.12.8-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update anaconda python-blivet'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-da7ada8825
Comment 8 Jan Stodola 2015-10-26 04:55:26 EDT
Closing as fixed (see comment 6)
Comment 9 Adam Williamson 2015-10-26 12:55:26 EDT
...except the update has not been pushed stable.
Comment 10 Fedora Update System 2015-10-26 17:00:40 EDT
anaconda-23.19.10-1.fc23, python-blivet-1.12.8-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.