Bug 1273013 - python-django-openid-auth-0.14 is available
python-django-openid-auth-0.14 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-django-openid-auth (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Marko
Fedora Extras Quality Assurance
: FutureFeature, Triaged
: 1438714 (view as bug list)
Depends On:
Blocks: PYTHON3 PY3PATCH-AVAILABLE
  Show dependency treegraph
 
Reported: 2015-10-19 08:11 EDT by Upstream Release Monitoring
Modified: 2017-06-09 15:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-django-openid-auth-0.14-1.fc26
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-09 15:03:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 0.7 (#1273013) (1.20 KB, patch)
2015-10-19 08:11 EDT, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.40 KB, patch)
2016-05-26 20:12 EDT, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.42 KB, patch)
2016-09-14 20:20 EDT, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.42 KB, patch)
2017-01-16 19:16 EST, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.42 KB, patch)
2017-01-23 19:11 EST, Upstream Release Monitoring
no flags Details | Diff
Update to 0.14 version including Python 3 subpackage (3.66 KB, patch)
2017-04-04 04:29 EDT, Jan Beran
no flags Details | Diff
Modified update to 0.14 version including Python 3 subpackage (3.65 KB, patch)
2017-05-18 03:49 EDT, Jan Beran
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2015-10-19 08:11:49 EDT
Latest upstream release: 0.7
Current version/release in rawhide: 0.5-5.fc23
URL: https://pypi.python.org/pypi/django-openid-auth

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-10-19 08:11:57 EDT
Created attachment 1084377 [details]
[patch] Update to 0.7 (#1273013)
Comment 2 Upstream Release Monitoring 2015-10-19 08:18:04 EDT
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=11498493
Comment 4 Upstream Release Monitoring 2016-05-26 20:11:56 EDT
Latest upstream release: 0.9
Current version/release in rawhide: 0.5-6.fc24
URL: https://pypi.python.org/pypi/django-openid-auth

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/3840/
Comment 5 Upstream Release Monitoring 2016-05-26 20:12:04 EDT
Patching or scratch build for python-django-openid-auth-0.5 failed.
Comment 6 Upstream Release Monitoring 2016-05-26 20:12:05 EDT
Created attachment 1162309 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 7 Upstream Release Monitoring 2016-05-26 20:12:07 EDT
Patches were not touched. All were applied properly
Comment 8 Upstream Release Monitoring 2016-09-14 20:19:56 EDT
Latest upstream release: 0.11
Current version/release in rawhide: 0.5-7.fc25
URL: https://pypi.python.org/pypi/django-openid-auth

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/3840/
Comment 9 Upstream Release Monitoring 2016-09-14 20:20:05 EDT
Patching or scratch build for python-django-openid-auth-0.5 failed.
Comment 10 Upstream Release Monitoring 2016-09-14 20:20:07 EDT
Created attachment 1201009 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 11 Upstream Release Monitoring 2016-09-14 20:20:08 EDT
Patches were not touched. All were applied properly
Comment 12 Upstream Release Monitoring 2017-01-16 19:16:15 EST
Latest upstream release: 0.12
Current version/release in rawhide: 0.5-7.fc25
URL: https://pypi.python.org/pypi/django-openid-auth

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/3840/
Comment 13 Upstream Release Monitoring 2017-01-16 19:16:24 EST
Patching or scratch build for python-django-openid-auth-0.5 failed.
Comment 14 Upstream Release Monitoring 2017-01-16 19:16:26 EST
Created attachment 1241504 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 15 Upstream Release Monitoring 2017-01-16 19:16:27 EST
Patches were not touched. All were applied properly
Comment 16 Upstream Release Monitoring 2017-01-23 19:11:46 EST
Latest upstream release: 0.13
Current version/release in rawhide: 0.5-7.fc25
URL: https://pypi.python.org/pypi/django-openid-auth

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/3840/
Comment 17 Upstream Release Monitoring 2017-01-23 19:11:55 EST
Patching or scratch build for python-django-openid-auth-0.5 failed.
Comment 18 Upstream Release Monitoring 2017-01-23 19:11:56 EST
Created attachment 1243786 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 19 Upstream Release Monitoring 2017-01-23 19:11:58 EST
Patches were not touched. All were applied properly
Comment 20 Upstream Release Monitoring 2017-04-03 20:11:36 EDT
Latest upstream release: 0.14
Current version/release in rawhide: 0.5-8.fc26
URL: https://pypi.python.org/pypi/django-openid-auth

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/3840/
Comment 21 Upstream Release Monitoring 2017-04-03 20:11:40 EDT
An unexpected error occured creating the scratch build: please report this issue to the-new-hotness issue tracker at https://github.com/fedora-infra/the-new-hotness/issues
Comment 22 Jan Beran 2017-04-04 04:29 EDT
Created attachment 1268580 [details]
Update to 0.14 version including Python 3 subpackage
Comment 23 Jan Beran 2017-04-04 04:32:20 EDT
May I ask for your review?
Comment 24 Iryna Shcherbina 2017-04-04 05:41:07 EDT
*** Bug 1438714 has been marked as a duplicate of this bug. ***
Comment 25 Jan Beran 2017-04-25 07:13:38 EDT
Hi Richard,

may I kindly ask you to check the attached specfile update for version 0.14?

Thank you.

Jan
Comment 26 Charalampos Stratakis 2017-05-16 10:52:22 EDT
Hello Jan and thanks for the patch, I am reviewing it now.

Could I ask the reason for excluding the "example_consumer" directory from the resulting RPM's?
Comment 27 Jan Beran 2017-05-17 08:45:04 EDT
Hi Harris,

if the directory is not excluded, RPM build error occurs because of installed but unpackaged files. I chose the exclusion as the directory is just an example that (I think) can be left out. May be that other solution could be to define a subpackage just for the example. Or do you have any other idea?
Comment 28 Jan Beran 2017-05-18 03:49 EDT
Created attachment 1279890 [details]
Modified update to 0.14 version including Python 3 subpackage

Hi Harris,

I have checked the previous 0.5 version where example_consumer dir were not packed even it was included in the source. It was because of missing django_openid_auth.egg-info that contains also example_consumer dir specification. So I modified the spec to respect django_openid_auth.egg-info and include example_consumer dir in the package.
Comment 29 Charalampos Stratakis 2017-05-19 11:48:21 EDT
(In reply to Jan Beran from comment #27)
> Hi Harris,
> 
> if the directory is not excluded, RPM build error occurs because of
> installed but unpackaged files. I chose the exclusion as the directory is
> just an example that (I think) can be left out. May be that other solution
> could be to define a subpackage just for the example. Or do you have any
> other idea?

Hello Jan,

You are right, this directory is an example. The approach on that depends on the packager's preference, however I believe including it should be fine, so I will push your latest changes.

Thanks.
Comment 30 Fedora Update System 2017-05-19 12:04:25 EDT
python-django-openid-auth-0.14-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7529d45c7a
Comment 31 Fedora Update System 2017-05-20 04:17:03 EDT
python-django-openid-auth-0.14-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7529d45c7a
Comment 32 Fedora Update System 2017-06-09 15:03:23 EDT
python-django-openid-auth-0.14-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.